iThemes Security (formerly Better WP Security)
[resolved] [Plugin: Better WP Security] Away Mode is keeping me Locked out (24 posts)

  1. dukejames27
    Posted 4 years ago #

    Ok, something wierd is happening. It's my first time using "Away Mode" and thankfully, at the top of the page, it mentioned the current time on the server. After realizing that it was 3 hours behind, I modified it to the correct time and then setup a simple daily rule to lock me out between 6:30pm and 6:40p.m. I was immediately locked out, however it's 30 minutes past and I can't seem to get back in.

    I've read an earlier post's instructions for fixing this issue within the database:

    You can manually turn it off if you're good with the database by changing the "am_enabled" to 0 in the settings array for the plugin

    The problem is, I don't see anything which says "am_enabled" and even when trying to do a search with phpmyadmin, nothing came up. I do see "bwps_away_mode" within the wp_options but changing that from '1' to '0' did nothing. I also see tables for the "bwps_lockouts" and "bwps_log" but I'm not seeing anything helpful.

    Luckily, I only have 4 plugins installed and it's on a test machine so there's no priority. I did this to better learn and understand BWPS. However, I would like to get a better explanation as to how I could recover the site without removing/renaming the plugin folder.



  2. dukejames27
    Posted 4 years ago #

    Oh crap. I moved the BWPS folder out of the plug-ins folder and still don't have access.

  3. dukejames27
    Posted 4 years ago #

    In the 'wp_options' I found a reference of


    There's a lot of code before and after that. Anyway, changing the 1 to 0 didn't help either.

  4. To get in quick remove bwps_awaymode from the database (this is something new in 3.4 to make it easier to revert these changes).

    Could you email me at info [at] bit51 [dot] com? This is a very heavily tested feature at a couple of universities (I've got it successfully locking out users on about 300 individual sites without a complaint) and I would really like to learn why it isn't working for you.

  5. dukejames27
    Posted 4 years ago #

    Deleting bwps_awaymode worked. Thanks and I also sent an e-mail confirmation.

  6. dukejames27
    Posted 4 years ago #

    This issue is resolved.

  7. bizolly
    Posted 3 years ago #

    Hi! I'm having the same problem. I really liked this plugin, but when I set the time it immediately locked me out. I did remove the bwps from the wordpress plugin folder so I could sign back in but as soon as I try to reinstall a new version, it locks me back out.

    I could only locate two bwps items in the database: log, another which I deleted so I could reinstall another time but this does not help. I cannot find the bwps_awaymode anywhere in database.

    Would love to use this on my site if you could guide me on how to repair/fix or reinstall.

    Thank you much in advance.

  8. delito
    Posted 3 years ago #

    I have locked myself out too. Reading the text above just confuse me. What should I exactly do to fix it?

    (Dette er virkelig noget skidt, er det!)

    Quote: "To get in quick remove bwps_awaymode from the database".

    Yes, but where?? :(

  9. delito
    Posted 3 years ago #

    Okay, I found out how to do it via the plugin -> inc -> secure.php

    It says bwps_awaymode two places in the file. At the bottom - and just before where it says am_enabled - must 1 be replaced with 0.

  10. delito
    Posted 3 years ago #

    Okay, I found out how to do it via ftp: The plugin -> inc -> secure.php

    It says bwps_awaymode two places in the file. Go to the lower of the two.
    With 'bwps_awaymode' and 'am_enabled' (just before) change 1 to 0. That's what I did. I get back my login page.

    Meybe that is easier to understand? My English is not good. Sorry!

  11. bizolly
    Posted 3 years ago #

    Still working on this. I'm getting another problem on a post. whenever I try to open the page I get this error message: The Google Maps API server rejected your request. The "sensor" parameter specified in the request must be set to either "true" or "false".

    This just began. I can only assume since I installed this plugin. Could you please get back to me. Thank you much!

  12. bizolly
    Posted 3 years ago #

    Delito: you were correct about breaking the lock out. I went into the C-Panel of my host and used the code editor to make this change. To Better Security Plugin located in the WPcontent/plugin folder. File: inc and code found on: secure.php; then I changed the 1 to 0 at both: bwps_awaymode references.

    Now, I've turned on most all the features of this plugin and I am having trouble. I can pull up the main page of the site but when I try to access the tabs at the top I get this error message:

    The requested URL /element-objectives/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    It is the same for all the other sites in the multi-site installation.

    Also, on one page only I'm still getting this error: The Google Maps API server rejected your request. The "sensor" parameter specified in the request must be set to either "true" or "false".

    Hope the web developer at Bit51 gets back to me soon!! Would love to use this plugin. I think it just needs some tweaking!!

  13. dukejames27
    Posted 3 years ago #

    Sorry guys, I marked this thread as resolved and never realized people were communicating here. I would've tried to mention what I did to get back in.

    @Carol Ickes - In terms of the Google Maps API error, have you fixed it? If not, have you searched through the forums here? I saw two threads which mentioned this issue and that they resolved it. Here are the links.



    The 404 error you mentioned sounds like a directory is being blocked from viewing. This is usually done to prevent a listing of file names and directories from being viewed. Check under the "Tweaks" section and see if you have the "Disable Directory Browsing" option enabled. If so, disable it and try again. If the page you were trying to view appears, then you should probably research further about the URL. In general, I think this tweak is a very good thing.

    As for the other message you mentioned "The requested URL /element-objectives/ was not found on this server.", it might also relate to the 404 error. I'm not 100% sure but after disabling the above tweak, the tabs may work and this issue may disappear.

    Good Luck!

  14. bizolly
    Posted 3 years ago #

    Hi dukejames27. Thanks for getting back to this. I would love to use this plugin. Been having problems with hackers.

    When I installed the plugin, got a long list of items that needed to be addressed using your security list. For whatever reason, I cannot install the .htaccess file you provided, or make many of the other changes. It crashes my site. I worked hours trying to get all of this work.

    Do you have any suggestions. I have your plugin disabled at the moment.


  15. For those of you with away mode issues what timezone are your sites in?

    @Carol do you know which line is causing errors?

  16. dukejames27
    Posted 3 years ago #

    @Carol - I'm just a friendly user like yourself. The away mode is my last hiccup with the plugin. I'm afraid to enable it. Every other feature is working well so far. In regards to installing the '.htaccess' file, is this for the away mode or a different feature. If different you may want to start a new thread for the topic.

    @bit51 - My server is located in EST.

  17. Thanks Duke. I'm going to try to tear that feature apart later this week and see if I can' recreate the problem.

  18. batec
    Posted 3 years ago #

    The away functionality has caught me up twice now. And following the directions to deactivate via the database are unclear.

    Where does bwps_awaymode reside in the DB?

    The only 2 references to bwps are "lockouts" and "logs" and I do not have a "wp_options"

  19. It is in your options table your_db_prefixoptions

  20. batec
    Posted 3 years ago #

    what I found is that for WP multi-sites the place to look is

    wp_1_options (if you have not modified the DB table names)

    I have also found that this feature works for a while and then resets itself to being active but running 24 hours, which locks everyone out of the site.

    I could modify the bwps_awaymode in the plugin >>secure.php by changing the 1's to 0's but this only gave me access to the child blogs not the blog network admin area.

    So for right now I have deactivated this feature. When it was working it was great... then it stopped.

  21. Interesting batec. I will look into the reseting issue.

  22. batec
    Posted 3 years ago #

    That would be great.

    I also just found that it re-activated itself today. Is there anyway I can remove any reference to awaymode as a precaution.

    Now that I know where to go in the DB I can at least turn it off, but I did find that I have to re-set it in the secure.php and the DB to regain access.

  23. As a worst case you could manually remove the check from the code in secure.php

  24. Swapnali
    Posted 3 years ago #

    hello guys,

    I am stuck in problem after installing wp security plugin my admin redirects to homepage. Plz help me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.