WordPress.org

Forums

iThemes Security (formerly Better WP Security)
[plugin: better-wp-security] admin login problems (3 posts)

  1. cjeyes
    Member
    Posted 2 years ago #

    Hi all,

    I think this problem has been caused by Better-WP-Security (ironically).

    I installed the plugin earlier this week but didn't look at my site (Fossenet.co.uk) again until this morning, when I found I could not login to the admin area as clicking on the admin link just resolved to the homepage, as did typing ...wp-admin or wp-login in the address bar.

    Following some other advice I renamed a couple of recent plugins (this one, and Pricing Table Pro) along with the Catalyst Dynamic theme folder.

    That enabled me to login, so I re-enabled and renamed plugins one by one. When I renamed and reactivated Better-WP-Security I was immediately logged out of the site and now everything apart from the homepage is a 404 error. The site is totally broken.

    I have tried changing names back again and even moving the plugin out of the directory altogether but that hasn't altered it.

    I also replaced the .htaccess file with a blank one, and subsequently one with the recommended rewrite code from the permalinks codex page.

    Site is still broken and I haven't a clue what to do. The irony of course is that in attempting to protect my site I appear to have broken it...

    Any ideas anyone?

    Many thanks,

    Chris

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Cheryl Fahling
    Member
    Posted 2 years ago #

    Thanks for reporting! I guess I'll wait to install the latest update. My site went white with a previous update, and I'm hesitant to have that happen again.

  3. cjeyes
    Member
    Posted 2 years ago #

    Just an update. Fossenet is now back online.

    This was a permalinks problem which I fixed by going into PHPMyAdmin and removing the pretty link option in the database. That then restored all functionality to the site and it now has pretty permalinks again.

    A frightening time but all now fixed.

    No idea whether it was to do with this plugin or not, but I'm using another solution just in case!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic