WordPress.org

Support

Support » Plugins and Hacks » Better WordPress Google XML Sitemaps (support Sitemap Index, Multi-site and Google News) » [Resolved] [Plugin: Better WordPress Google XML Sitemaps (with sitemapindex and Multi-site support)] 404 Error

[Resolved] [Plugin: Better WordPress Google XML Sitemaps (with sitemapindex and Multi-site support)] 404 Error

  • 2 site multisite Running W3TC 0.9.2.4. I get 404 error when trying to open sitemapindex (http://mysite.com/sitemapindex.xml).

    I’ve tried the suggestions here and here, and cannot solve it.

    I don’t have this in my .htaccess file:

    RewriteCond %{REQUEST_URI} !(robots\.txt|sitemap(_index|[0-9]+)?\.xml(\.gz)?)

    I have this on 2 lines of each W3TC Page Cache Core:

    RewriteCond %{REQUEST_URI} (sitemap\.xml(\.gz)?) [NC]

    Tried to change it as suggested in the links above and it caused an internal server error and crashed the sites. Replaced the original code and all is well, but I’m uninstalling for now. There really isn’t very much help for multisite with W3TC, and I’ve spent WAY too many hours already.

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Khang Minh

    @oddoneout

    Changing .htaccess file should be done with caution, you can’t just copy / paste and hope it work instantly. Please use the contact form: http://betterwp.net/contact/ to send me your .htaccess file, and I will see if there’s anything I can do.

    @OddOneOut- Thanks- will do- greatful for any assistance!

    Also, even if I get the code right, W3TC is going to change it every time i make any settings changes….

    Plugin Author Khang Minh

    @oddoneout

    I’ve received the message. It seems that you’re using an old version of W3TC. Anyway, if you want to keep the settings, go to Performance > Browser Cache, and then go to ‘404 error exception list:’ in the General option block, find this line:

    sitemap\.xml(\.gz)?

    and change it to:

    (sitemapindex|[a-z0-9_-]+)\.xml)

    Please tell me if it works for you.

    @OddOneOut- Thanks. As stated on the 1st line of my first post, I’m using the latest Version 0.9.2.4 of W3TC. I will try the change you suggest and let you know…..

    Which activation is preferred: network or individual sites? Unless I hear otherwise, I’m activating per site.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@trianglehomesuccess.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at trianglehomesuccess.com Port 80

    Plugin Author Khang Minh

    @oddoneout

    Okay please don’t revert the change, and send me your new .htaccess file (after you changed that line, you told W3TC to put new rules in .htaccess right?)

    Btw, you can safely activate the plugin network-wide, it doesn’t matter.

    Sending now- Thanks!

    Plugin Author Khang Minh

    @oddoneout

    Hi, that was my mistake, sorry. Now you should manually edit your .htaccess file, and then find the part you just added, which is:

    (sitemapindex|[a-z0-9_-]+)\.xml)

    and then replace it with (actually, just remove the last parenthesis):

    (sitemapindex|[a-z0-9_-]+)\.xml

    Once you get back to the site, go to the Browser Cache tab again and make the same change ;).

    I already changed the .htaccess line to:
    RewriteCond %{REQUEST_URI} !(robots\.txt|sitemap\.xml(\.gz)?)
    so I could get back in.

    Should I now go to browser cache settings and make the change?

    Also, page cache settings contains the following under Non-trailing slash pages: sitemap\.xml(\.gz)? Should I change that as well?

    Plugin Author Khang Minh

    @oddoneout

    Of course.

    Also, page cache settings contains the following under Non-trailing slash pages: sitemap\.xml(\.gz)? Should I change that as well?

    That will allow you to cache sitemaps produced by BWP GXS, but since my plugin already has its own caching mechanism, it’s up to you.

    New settings works and works.

    Should I do anything with that page cache setting? Also, not exactly sure how to ‘submit’ after configuring?

    Thanks so very much for taking the time to help. I wish I’d thought to look at W3TC browser cache yesterday while fretting over this. This would be a really simple addition/change for you to make in your FAQs for the many W3TC users, when you get a chance. Thank you so much!

    That will allow you to cache sitemaps produced by BWP GXS, but since my plugin already has its own caching mechanism, it’s up to you.

    What do you recommend? Can I just take that out of the exceptions field and let your plugin handle it?

    Also, under W3TC page cache settings, cache preload,Sitemap URL: what link should I put here? The W3TC default is http://mysite.com/sitemap.xml

    Plugin Author Khang Minh

    @oddoneout

    Glad it’s working!

    This would be a really simple addition/change for you to make in your FAQs for the many W3TC users, when you get a chance.

    What you read in the FAQ is correct, I really don’t know why it didn’t work for you though.

    What do you recommend? Can I just take that out of the exceptions field and let your plugin handle it?

    Well, if you use BWP GXS’s caching mechanism, sitemaps will be cached independently with its own expiry time, which is basically the main benefit. To avoid unnecessary issues that might arise, I suggest using mine.

    Also, under W3TC page cache settings, cache preload,Sitemap URL: what link should I put here? The W3TC default is http://mysite.com/sitemap.xml

    That is for the old sitemap thing, where all URLs are listed there. I’m not sure if that feature works with a sitemap index, but you can leave it as is.

    What you read in the FAQ is correct, I really don’t know why it didn’t work for you though.

    Because I was changing the code in the W3TC Page cache Core rules instead of the 404 rules. Maybe I missed that in the FAQ.

    Thanks for all your help, and for making the plugin available. Still not clear on how to ‘submit’ to search engines. Do I go to their sites for that?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] [Plugin: Better WordPress Google XML Sitemaps (with sitemapindex and Multi-site support)] 404 Error’ is closed to new replies.
Skip to toolbar