Support » Plugin: Better Recent Posts Widget » [Plugin: Better Recent Posts Widget] Widget shows only on Home page

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Pippin Williamson

    (@mordauk)

    Are each of the posts listed in the widget available in English? I believe WPML has a setting to not show posts if they don’t have a translation.

    The posts are in Spanish (default) only. Is there a way to alter the widget to display them anyway? Or does that involve editing wpml as well?

    Plugin Author Pippin Williamson

    (@mordauk)

    Did you find the setting in WPML that makes it so that posts are displayed in the default language if the selected language isn’t present?

    In WPML there is this option

    Blog posts to display
    Only translated posts.
    *All posts (display translation if it exists or posts in default language otherwise).

    I have selected the second option but no difference. I don´t want to edit wpml files manually because it will get wiped on upgrade.

    Plugin Author Pippin Williamson

    (@mordauk)

    Ask the developer of WPML, perhaps he can give you a clue. The widget displays posts just like any other template file or widget, so there is really nothing that could be causing the issue in the widget. If I knew more about how WPML worked, I’d try and help further, but I have no idea. Sorry.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Better Recent Posts Widget] Widget shows only on Home page’ is closed to new replies.