WordPress.org

Support

Support » Plugins and Hacks » bbPress New Topic Notifications » [Resolved] [Plugin: bbPress New Topic Notifications] New Topic Notifications not being sent…

[Resolved] [Plugin: bbPress New Topic Notifications] New Topic Notifications not being sent…

  • I’m running the most recent versions of WP and bbPress. For some reason the bbPress New Topic Notifications is not sending email notifications when topics are added.

    I have another site that is almost identical, running the same WP version and plugins, and it is working fine (both are with the same host as well). I have been troubleshooting this all day but with no success… aaarrgh!

    Any help with this would be greatly appreciated.

    http://wordpress.org/extend/plugins/bbpress-new-topic-notifications/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Jared

    @jaredatch

    @kevinvaughn – thanks for letting me know!

    What host is the site that you are having trouble with on?

    The plugin uses the WordPress mail function ( wp_mail() ), however some hosts do have problems with it. Do you receive other notifications such as commets/trackbacks?

    Thanks jaredatch, for your input. Yes it has to do with the wp_mail() function. The problem has been resolved, see the following thread on s2Member’s site…

    http://www.primothemes.com/forums/viewtopic.php?f=4&t=15555

    Plugin Author Jared

    @jaredatch

    Excellent, thanks for the update 🙂

    My notifications are not being sent. I have looked at the thread at http://www.primothemes.com/forums/viewtopic.php?f=4&t=15555 and I don’t have those issues involving the MTA. My other notifications from the WP portion of my site work just fine, for example from the Subscribe2 plugin.

    I have the sender set elsewhere as being a registered member. I have all registered members in the box as recipients and none of them get emails.

    This is hosted on hostgator.
    Tell me where to troubleshoot please.
    gil

    Plugin Author Jared

    @jaredatch

    I’m not quite sure what to tell you. Are you using the latest version of bbp and WP (3.3)?

    I actually use HostGator for some of my own sites and haven’t noticed a problem.

    I am on bbPress 2.0 (via the plugin) and WP 3.2.1.

    Plugin Author Jared

    @jaredatch

    Few things I would try:
    – Update bbP (2.0.2) and WordPress (3.3)
    – disable all the plugins other than bbp and bbp notifications
    – turn on WP_DEBUG (in wp-config) and see if something is conflicting

    I just tested it on a test setup I have (WP nightly trunk, bbp 2.0.2) which is on HostGator and I got the notification no problem.

    My apologies. I AM on bbP 2.0.2. I also misspoke about the host. This one is on lunarpages.

    – Reluctant to do WP 3.3 until I know all of the plugins I use are up to date.
    – Did the disabling. No change, no notifications.
    – here are the debug results. I don’t see anything that’s obvious to me, but I’m not a coder, either.

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /home/daybr2/public_html/wp-includes/functions.php on line 3468

    Notice: Use of undefined constant MobileSmart_ap – assumed ‘MobileSmart_ap’ in /home/daybr2/public_html/wp-content/plugins/mobile-smart/mobile-smart.php on line 907

    Notice: Use of undefined constant post_content_shortcodes – assumed ‘post_content_shortcodes’ in /home/daybr2/public_html/wp-content/plugins/post-content-shortcodes/post-content-shortcodes.php on line 11

    Notice: Trying to get property of non-object in /home/daybr2/public_html/wp-includes/functions.php on line 155

    Notice: Trying to get property of non-object in /home/daybr2/public_html/wp-includes/functions.php on line 155

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3382

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3382

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3466

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3466

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3466

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3466

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/daybr2/public_html/wp-includes/functions.php on line 3466

    Warning: Cannot modify header information – headers already sent by (output started at /home/daybr2/public_html/wp-includes/functions.php:3468) in /home/daybr2/public_html/wp-includes/pluggable.php on line 934

    Plugin Author Jared

    @jaredatch

    I don’t see anything in that notice/warning log that would be causing it.

    It is likely an issue with your host (using QMail) and you can read more about it at http://www.primothemes.com/forums/viewtopic.php?f=4&t=15555#p48533 as well as some possible fixes that might work. I would definitely recommend trying option #1 first!

    I did discover that lunarpages uses qmail. Yuk.
    I did the #1 fix. The WP SMTP plugin sends a test mail to me just fine.

    Still no notifications although I
    – disabled all unneeded plugins
    – deactivated, deleted, and re-added your plugin

    Still nothing. I may try the \n fix next.

    The \n fix did not work either.
    Stumped.

    One other thought. This is on a subsite of a multisite installation. Could that make a difference?

    @jaredatch
    Bumping this.
    Any thoughts about the sub-domain site possibly being an issue?
    I am getting notifications through Subscribe2 plugin of normal posts and in the test emails via the smtp plugin.

    gil

    Plugin Author Jared

    @jaredatch

    Unfortunately I don’t really have a good solution. The web hosts/server environments I have access to and test on don’t have this issue.

    I don’t see how being on a sub domain would be an issue, but I’ll test it this week just to rule it out!

    @jaredatch — have you had a chance to look further into this? I’m still not getting notifications to my sub-domain bbPress 2.0.2 install.

    Plugin Author Jared

    @jaredatch

    Alright, I looked at it this morning.

    As I suspected, it has to be something with your hosting setup.

    Earlier today I setup test.mydomain.com (sub domains) on *two* different hosting environments, both running WP 3.4 trunk, bbP 2.x trunk, and latest version of my plugin.

    I was able to receive the notifications on both test setups without any issues. I wish there was more I could do but sadly I think it it has something to do with the host (running qmail probably). I have access to 4 different server environments and I can’t reproduce this bug on any of theme. Additionally the plugin has now been downloaded over a 1,000 times and most people don’t seem to have an issue :\

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] [Plugin: bbPress New Topic Notifications] New Topic Notifications not being sent…’ is closed to new replies.
Skip to toolbar