WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Basic Google Maps Placemarks] Map not loading after update

[Resolved] [Plugin: Basic Google Maps Placemarks] Map not loading after update

  • I have updated to the latest version of bgmp and now my maps are not loading.

    My site was working perfectly fine before hand and I did not updated any other plugins at the same time.

    I’ve spent the last 3hours searching forn answers and trying to get this resolved but to no avail.

    Here’s one of the pages where a map should be.
    http://www.norfolkplaces.com/indoor-soft-play/
    On this page I have this shortcode:-
    [bgmp-map categories=”indoor-soft-play”]

    Category based maps on my site is a key feature, so unfortunately it looks like I’ll have to search for a more reliable plugin if I can’t get this resolved soon.

    http://wordpress.org/extend/plugins/basic-google-maps-placemarks/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Luckily I had taken a back-up of my site a couple of days ago so I’ve reinstalled the files from the previous version of this plugin.

    Not really a resolution, so I guess I’ll wait until the compatability/bug issues in v1.9 are sorted.

    Plugin Author Ian Dunn
    Participant

    @iandunn

    Hi Majato, I noticed you’re using W3 Total Cache; did you clear the cache after the upgrade? If not, that would probably cause it to break, since there were some changes to the directory structure.

    Also, make sure you clear your browser cache, since old data in your browser would make it fail for you, even though it worked for people with clean caches.

    Do you have a staging site you can test out the upgrade on? I’ll need to see the actual problem in order to troubleshoot it.

    I tested the plugin on my and didn’t find any bugs, and also issued a release candidate two weeks ago, and nobody raised any issues.

    If your site requires 100% uptime, then I’d recommend hiring a developer who can test out early releases of the plugin on a staging server, and then submit patches for any bugs that were found in the plugin, the theme or other plugins. Then, the final release should also be tested on a staging server before being installed on the production server.

    You can’t expect someone who’s already given you hundreds of hours of free work to also perform exhaustive testing and extensive support.

    magic_square
    Member

    @magic_square

    Hi Ian, I have the same problem as majato – maps not loading after updating to v1.9.1 that worked well before the update. I’m also using 4.3.2 and W3TC, but clearing all caches (and on the browser) has not resolved the problem.

    I’m just in the process of setting up a staging server, so on a clean Wp install with 2011 theme (and no other plug-ins) I get a loaded map but the same error:-

    “Basic Google Maps Placemarks shortcode error: is not a valid category.”

    The short code I am using is [bgmp-map center=”uxbridge uk” zoom=”13″ height=”300″ width=”750″], so is a category now a required field?

    live site: http://www.pilates4life.co.uk/courses/maps

    Thanks for all your help

    Hi Ian,

    Yeah, I cleared the cache. AFter the bug occurred I read through the FAQs etc which mentioned about issues with W3.

    I don’t have an upto date staging site but I was planning to build one next weekend, so will have to move my plans forward.

    Plugin Author Ian Dunn
    Participant

    @iandunn

    Thanks for the details magic_square. I was able to reproduce the bug in 1.9.1 that caused that, and fixed it in 1.9.2.

    Can you please try upgrading and let me know if you have any more problems?

    Also, I noticed that your page is including the Google Maps API twice, which may cause other problems. It’s probably being included the second time from the theme or another plugin.

    magic_square
    Member

    @magic_square

    Thanks for the fast update Ian. Have upgraded and error message has gone, but maps still not loading on live site.

    Will look at the duplicate API issue, but duplication was also there before the 1.9.1 upgrade and all plug-ins seem to co-exist then.

    Plugin Author Ian Dunn
    Participant

    @iandunn

    Yeah, it looks like there’s a syntax error in the bgmpData.markers JSON array on your site. Working on it…

    magic_square
    Member

    @magic_square

    Fantastic support Ian, I really appreciate it. Deactivating the other map plug-in hasn’t changed anything.

    Plugin Author Ian Dunn
    Participant

    @iandunn

    For some reason there are line breaks in the details value for each marker in the array:

    "details":"
    <p>Our Lady of Lourdes and St Michael Catholic Church<br \/>\nOsborne Road<br \/>\nUxbridge UB8 1UE<\/p>\n"

    …when it should be

    "details":"<p>Our Lady of Lourdes and St Michael Catholic Church<br \/>\nOsborne Road<br \/>\nUxbridge UB8 1UE<\/p>\n"

    I’m having trouble reproducing it on my server, though, and there isn’t really anything that changed from 1.8 that should affect that. Still looking into it…

    Plugin Author Ian Dunn
    Participant

    @iandunn

    I’ve reverted the stable tag back to 1.8 until all of these issues are resolved. Once I figured out the line break issue, I’ll post a new 1.9 release candidate for people to test on staging servers before releasing a stable 1.9.3 release.

    magic_square
    Member

    @magic_square

    Thanks for such an honest response. Have reverted back to 1.8 and all is well.

    v1.9.2 looks ok on the staging server (although it should be noted the staging server is not a full replica of the live site – I’m still working on that. Let me know when you have a new version to test.

    OC2PS
    Participant

    @sooskriszta

    Same problem at http://www.csillamvilag.com/viszonteladok/

    I will revert back to 1.8

    Thanks for your hard work Ian.

    Plugin Author Ian Dunn
    Participant

    @iandunn

    Fixing this and releasing a stable 1.9 branch is still on my TODO list, but I’ve been pretty busy the past couple weeks, and it doesn’t look like that’s going to change soon.

    I’ll eventually find time for it, but if anyone wants to help the process along, these two things would help a ton:

    1. Figure out how to reliably reproduce the bug that magic_square and OC2PS reported, where the line break in bgmpData.markers causes a fatal JavaScript error
    2. Write unit tests that expose the underlying condition that causes the bug, and tests any related code to ensure that condition is prevented and/or handled gracefully
    Plugin Author Ian Dunn
    Participant

    @iandunn

    I’ve issued a new release candidate that hopefully fixes these bugs, but I’m still not able to reproduce them, so I’ll need you guys to help test it out to make sure everything is good.

    You can download the new RC at http://downloads.wordpress.org/plugin/basic-google-maps-placemarks.1.9.3-rc1.zip

    If possible, install it on a staging server. That way your live site won’t be harmed if there is still a bug, and also you’ll be able to leave the error in place for me to inspect.

    I’ve also setup an email list to notify everyone when new RCs are available in the future. That way you’ll have time to test it out on your staging server, and we can work out any bugs before the official release.

    Hi Ian,

    Thanks for the update. I’ve put it on my staging site and I’m still getting the same error (i.e. “loading map….”)

    Here’s an example page from the test site.
    http://images.norfolkplaces.com/indoor-soft-play/

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] [Plugin: Basic Google Maps Placemarks] Map not loading after update’ is closed to new replies.