WordPress.org

Forums

Basic Google Maps Placemarks
Fullscreen (6 posts)

  1. gummlion
    Member
    Posted 2 years ago #

    So, i really can't override the styles to the map.
    I need a full screen map on my homepage..so:

    1) I have added

    function setBGMPStyle()
    {
        wp_deregister_style( 'bgmp_style' );
        wp_register_style(
            'bgmp_style',
            get_bloginfo('template_url') . '/bgmp-style.css'
        );
        wp_enqueue_style( 'bgmp_style' );
    }
    add_action('init', 'setBGMPStyle');

    in my theme's functions.php file

    2) Then I saved this bgmp-style.css in my theme folder:

    #bgmp_map-canvas
    {
    	width: 100%;
    	height: 100%;
    }

    As you can see from my test blog here: smll.eu/maps I get always the default settings.

    Can someone help me out?
    Thank you!

    http://wordpress.org/extend/plugins/basic-google-maps-placemarks/

  2. Ian Dunn
    Inactive
    Plugin Author

    Posted 2 years ago #

    It looks full screen to me in Firefox.

  3. gummlion
    Member
    Posted 2 years ago #

    mhhhh, are you sure?
    I update the settings to 500x500px, and I still see a square. I need a 100% width and height map, something like this

  4. Ian Dunn
    Inactive
    Plugin Author

    Posted 2 years ago #

    It was last night, but now it's 500x500.

    Try entering "100%" into the settings width/height fields on the Settings page, or in the [bgmp-map] shortcode.

    If that doesn't work, add !important declarations to your CSS rules, like

    #bgmp_map-canvas
    {
    	width: 100% !important;
    	height: 100% !important;
    }
  5. MacGreenbear
    Member
    Posted 2 years ago #

    I am trying to achieve a responsive width here as well. I've tried the above suggestions but I just keep getting a width of 300px along with an error that my width is not valid.

    100% width would be very handy especially for responsive themes...can anyone let me know how to override the width issue?

  6. Ian Dunn
    Inactive
    Plugin Author

    Posted 2 years ago #

    Setting the option to "100%" is working in my tests. Keep in my that it will be 100% width of the container element, so if your container will need to be 100% (and so will its container, etc).

    What's the exact text of the error you're getting?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Basic Google Maps Placemarks
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.