[Plugin: Bad Behavior] Automatic update from 2.0.16->2.0.17 fails (10 posts)

  1. Nommo
    Posted 8 years ago #

    Tried this on 2 different WP 2.5.1 blogs - both times I tried to update automatically, it fails the upgrade, but succeeds in removing it.

    It seems to leave the folder intact, but deletes bad-behavior-wordpress.php


  2. error
    Posted 8 years ago #

    I suspect something went wrong at wordpress.org. Try 2.0.18.

  3. onewalrus
    Posted 8 years ago #

    Are you using the wordpress wp-autoupgrade plugin?

  4. Chiming in to say the same happened to me, also with updating to 2.0.18.

  5. Nommo
    Posted 8 years ago #

    onewlarus: I am usingthe auto-upgrade process that comes out of the box with 2.5.x

    "There is a new version of Bad Behavior available. Download version 2.0.18 here or upgrade automatically."

    I just tried with 2.0.18 - same result - end result - no bad behaviour plugin.

    "Downloading update from http://downloads.wordpress.org/plugin/bad-behavior.2.0.18.zip

    Unpacking the update

    Deactivating the plugin

    Removing the old version of the plugin

    Installing the latest version

    Installation failed"

  6. error
    Posted 8 years ago #

    I'd like to fix this, if it's a problem on my end (and not a problem with your web hosting provider, or with WordPress itself). Please check the server's error_log to see what errors were logged when the upgrade failed. Thanks!

  7. Nommo
    Posted 8 years ago #

    Hi error,

    OK - well - these WP installs are on two different servers - one private corporate server (which I don't have FTP or Command Line Access to), and one on shared hosting on Dreamhost (which I do have FTP and CL access to). So not exactly scientific, but suggests it's not the server to me. Could be WP, we just had to hack the core to get post author to get comment notifications (on the corp server) - so I wouldn't be surprised...

    Just looking through the logs on Dreamhost looking for something relevant to this - not seeing anything as yet... it's all about missing favicon.ico and missing.html and robots.txt on the root directory (not the blog subdir);-)

    BTW - same thing happens with the latest 2.0.20

    ETA: I just upgraded 'sociable' plug-in successfully using the auto-upgrade function... if that helps!

  8. Roy
    Posted 8 years ago #

    I use the One Click Plugin Updater Plugin and had no problems going from 2.0.16 to 2.0.20.

  9. Nommo
    Posted 8 years ago #

    Meh! I gave up on the one on Dreamhost... I deleted the old bad-behaviour (2.0.16) and manually installed the latest (2.0.20)

    The 'corp' blog isn't actually using bad-behaviour in anger yet (I am running a trial with 'open comment posting' on the dreamhost one first).

    I also upgraded to WP 2.6 today before giving up... that didn't make any difference - apart from letting me know that it couldn't create the 'bad-behaviour' directory, which is a new style of error report.

    I presume this failed because it didn't/couldn't delete the old one?

  10. error
    Posted 8 years ago #

    Gawd only knows. One little permission/ownership problem and the WP plugin updater(s) fail. And I mean epic fail. Without clue as to why. So this sort of thing is often difficult to pinpoint. At least I can sleep at night knowing it's not my fault. :)

Topic Closed

This topic has been closed to new replies.

About this Topic