WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
[resolved] [Plugin: BackWPup] unable to upload to S3 using AWS Identity users (3 posts)

  1. chodorowicz
    Member
    Posted 4 years ago #

    I'm trying to backup to S3. I've created users using with AWS Identity and Access Management. Unfortunately BackWPup doesn't recognize them - "No Buckets found! Or wrong Keys!".

    AWS Identity and Access Management
    http://aws.amazon.com/iam/

  2. chodorowicz
    Member
    Posted 4 years ago #

    OK, problem solved. I had to allow this user additional privileges (listing all buckets)

    {
      "Statement": [
        {
          "Effect": "Allow",
          "Action": ["s3:ListBucket","s3:PutObject","s3:GetObject","s3:DeleteObject"],
          "Resource": ["arn:aws:s3:::your-bucket/folder", "arn:aws:s3:::your-bucket/folder/*"],
          "Condition": {}
        },
        {
          "Sid": "Stmt1298301460014",
          "Action": [
            "s3:ListAllMyBuckets",
            "s3:ListBucket"
          ],
          "Effect": "Allow",
          "Resource": "arn:aws:s3:::*"
        }
      ]
    }
  3. ObviousIdea
    Member
    Posted 3 years ago #

    Can you be more specific ? it is a code you have added to S3 web site or wordpress ?
    in both case, please give more instructions as you solved it by yourself, and I Have the same error message than you describe.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags