Support » Plugin: BackWPup - WordPress Backup Plugin » [Plugin: BackWPup] Unable to allocate memory for pool

  • BackWPup Version 2.1.15
    W3TC Version

    I just installed W3TC includin configuring both memcached and Alternative PHP Cache (APC) onmy VPS host.

    Ran manual backups and received multiple warnings in first few lines and at the end of the jobs:

    [WARNING] require_once() [function.require-once]: Unable to allocate memory for pool.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I had similar problem and here is how I fixed it.
    First I thought, something was wrong with the backup-plugin so i tested other backup plugins but same php out of memory error. For example

    “Database error MySQL server has gone away for query”


    “Cannot allocate sufficient memory”

    So I thought something wrong with php memory. Then some articles suggested to edit wordpress’s .db files or some other files in cpanel, to increase memory or time limit, but those tricks didnot work out.

    Finally I came to know that one of the possible reason for memory error is, your mySQL file is too big (something like more than 200MB) That’s why memory runs out while doing things like backup. The culprits are following plugins-

    You may be using one or both of following plugins
    1. Better WordPress security
    2. Akismet spam remover

    both of them create ‘logfiles’ in your MYSQL file and over the time, because of them, the SQL file becomes very huge.
    So, you’ve to goto phpmyadmin >> empty the tables that contain those logfiles.
    Then try to take backup again and it’ll run smoothly.

    In my case, Better WordPress Security alone had huge logfile of 480MB inside mysql. When I emptied the “wp_bwps_log”, the size of mysql file was reduced to barely 47MB (for 700 posts and 3000 comments on my site.)
    And then I tried to take backup using “BackWPup” plugin and it worked smoothly without any problem.

    I have two WP installs and I delete and purge Akismet Spam and redirection log every day and my databases are not large.
    Web has a 1.6MB SQL file with only wp_commentmeta 38KB
    Blog has a 8.7MB SQL file, wp_commentmeta 370KB

    This issue started when I installed W3 Total Cache 3 days after moving my sites.

    I have the same, following the APC installation. My database is quite small.

    i increased the php memory from 128M to 256M, and now i went from 9 warnings to a single one:

    [WARNING] require_once(): Unable to allocate memory for pool.

    APC memory is too low, could you check if this is the problem?

    My errors became less frequent after adjusting W3TC settings but they still occur.

    I was going to increase APC memory but could not determine where to make the change – at the host level or under the W3TC config’s.

    apc.ini at host level.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: BackWPup] Unable to allocate memory for pool’ is closed to new replies.