WordPress.org

Support

Support » Plugins and Hacks » BackWPup - WordPress Backup Plugin » [Resolved] [Plugin: BackWPup] ‘Run Now’ shows a blank page.

[Resolved] [Plugin: BackWPup] ‘Run Now’ shows a blank page.

  • In latest WP 3.0, running the backup job gives no output in its iframe. PHP 5.1.6 running in suphp and backwpup is 1.0.3. I’m sure that the logs, temp and backup location directories have write permissions for the user that runs suphp. But the error of blank page is not understandable yet.
    Any opinions?

    http://wordpress.org/extend/plugins/backwpup/

Viewing 15 replies - 1 through 15 (of 26 total)
  • Same problem here. But I’m still running the older wp 2.9.2.
    The problem does not exist in backwpup 0.8.1, but it does in 1.0.x
    And I use PHP: mail()

    Plugin Author Daniel Hüsken

    @danielhuesken

    hi,

    I Search for the Problem a Long time.
    On my host i have the problem only after the 1. runnow on a day.
    an my local test system i don’t have the problem.
    i think ist a cache problem.
    the problem exists in 0.8.1 too.

    I’m open for any idea to resolve the problem.

    Plugin Author Daniel Hüsken

    @danielhuesken

    the seduled run works every time normal.

    Plugin Author Daniel Hüsken

    @danielhuesken

    its the browser cashe that make the problem on my host!!!

    Plugin Author Daniel Hüsken

    @danielhuesken

    please redownload 1.0.3 now. I think i have fixed it now with some aditional php header setings for the page.

    please give feadback if its work.

    Thanks Daniel. Actually the problem occurs even I’ve cache plugin removed or deactivated. I just downloaded newer 1.0.3 but it still shows off the blank page.

    Ironically, its scheduler is also not working for me. Only creates null log files and not any back archives.

    Is it possible for you to add some sort of error handling or debugging features to backwpup? Or I guess, there should a compatibility checking tool that should check server or PHP runtime environment to find out if its supported for backwp or not!

    Some of my tests:

    * WordPress 2.6 with Backwpup 0.8.0 works pretty well.
    * WordPress 3.0 with Backwpup 0.8.0 works too.
    * WordPress 3.0 with Backwpup 1.0.3 fails with blank page.

    Plugin Author Daniel Hüsken

    @danielhuesken

    hmmm the ony change is i us the function plugins_url() to genarate the url for the iframe.

    please go too run now page and let you show the score code.
    look for a line with <iframe src=”…..”>.
    look the url behind src exists. and give feadback.

    Yep, it exists. Path of iframe is correct.

    /plugins/backwpup/app/options-runnow-iframe.php?ABSPATH=%2Fvar%2Fwww%2Fdomain.com%2F&jobid=1&_wpnonce=26a9b8270d

    translates to /var/www/domain.com/

    I also tried enabling full PHP error debugging but its the same, lol.

    memory_limit = 200M
    error_reporting = E_ALL
    display_errors = On
    short_open_tag = On

    Plugin Author Daniel Hüsken

    @danielhuesken

    /plugins/backwpup/app/options-runnow-iframe.php?.. loks wrong.
    musst http://yordomain.tld/plugins/backwpup/app/options-runnow-iframe.php?..

    please check your “Site address (URL)” and “WordPress address (URL)” setting!

    Sorry for the confusion. I pasted rest of the URL. It does have domain.tld.

    Do let know if there’s anything else you want to have checked?

    Plugin Author Daniel Hüsken

    @danielhuesken

    sorry in the moment i have no idea. i musst see it.
    its inthe score code of the iframe anything?

    The iframe shows up a blank page and there’s nothing in its source code unfortunately

    I meant in the browser. The actual iframe php file does have code but for some reason it’s not executing and showing a blank page instead :*(

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] [Plugin: BackWPup] ‘Run Now’ shows a blank page.’ is closed to new replies.
Skip to toolbar