WordPress.org

Forums

BackWPup Free - WordPress Backup Plugin
[Plugin: BackWPup] Notice: has_cap was called with an argument that is deprecated since version 2.0 (1 post)

  1. opicron
    Member
    Posted 4 years ago #

    Hi, again thanks for this plugin. It is working just fine.

    But there is an notice which WP is throwing when in debug mode. It is the following:

    - Notice: has_cap was called with an argument that is deprecated since version 2.0!

    Consider the statement of one of these functions:
    <? Php add_menu_page ($ page_title, $ menu_title, $ capability, $ menu_slug, $ function, $ icon_url, $ position);?>

    The third parameter, $capability, accepts as a value that defines the different capabilities WordPress. This menu give access to only users (roles) that have that capability.

    The error in question is generated because we do not pass a value of type capacity, we offer a value of type User Level, the old system to limit user roles.

    Looking forward to your fix!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags