Support » Fixing WordPress » [Plugin: BackWPup] Backup does not run

  • Hi Daniel,

    I have several WordPress sites all with BackWPup installed and on every one when I create a job and run it it always sits at 0% and does nothing but count up the time.

    All I get in the log if i abort the job is “2011/12/20 21:32.26: [ERROR]Aborted by user!!!”

    Can you or anyone else help me? I have upgraded to the latest version 3.3 of WordPress and the latest version of BackWPup and still had no joy.

    I have heard great reviews of the product however cannot get it to run. I am hosting on shared servers however all the sites my own domains and spread across different servers from the same provider.

    I did look through the settings in case I missed anything and spotted this “Http basic authentication” however I’m not sure if this applies or not and if it does is it the username and password for the WordPress login or the database I should use please?

    Any help would be greatly appreciated as I’d love to use the product.

    Thank you in anticipation.

Viewing 10 replies - 1 through 10 (of 10 total)
  • @rampling

    I ran into a similar issue today. I have a wordpress 3.3 site running fine with a hosting provider. I created a new account (new hosting/domain) with them and installed just the same, but the BackWPUp did not run. It just stayed at 0% with no logfile updates until aborted. Just a minute ago I got it to run. What did I do? Not 100% sure, but I added a few lines to wp-config.php, viewed the site and it worked. The backup job actually “stopped due to inactivity” and then restarted and created the backup”. I then tested that it would work using ‘run now’ on the job. It did. I then removed the lines and it still worked.

    I’m guessing that by updating the wp-config.php it somehow triggered the site to re-read it and reset whatever state it was in. (perhaps some left over “DOING_CRON” setting somewhere??

    The lines I added (and removed) were:

    define('WP_DEBUG', true);  // actually changed this to true and then back to false
    // added these lines to log php errors
    @ini_set('log_errors','On'); // enable or disable php error logging (use 'On' or 'Off')
    @ini_set('display_errors','Off'); // enable or disable public display of errors (use 'On' or 'Off')
    @ini_set('error_log','/tmp/php-errors.log'); // path to server-writable log file

    Not sure if those lines did the trick, or if any line(s) would do the trick. But it’s working and i’m not going to bother anymore untless it stops.

    Good luck!

    I am getting the same thing. This is a new install of 3.3 using Installatron. I have tried adding the debug lines to wp-config and have deactivated all other plugins. I have never had a problem with BackWPup before this.

    Any Solutions?

    I added this to my wp-config.php and everything is off and going again. Don’t ask me why, I have do some more reading on that.

    define(‘ALTERNATE_WP_CRON’, true);

    I now get “/?doing_wp_cron=1326762491” at the end of the url on the home page. Probably not a big deal, but…

    Did you fix this Darren?

    This sounds like just the plugin I need, but if it does nothing and sits at 0%, then it’s not very useful. I don’t mind editing the config file, but that really should NOT be needed, and if that adds that ugly querystring to the home page, then it’s not an option at all.

    Any other suggestions from the author?

    @pkiula, this is a brilliant plug-in, Daniel has done an amazing job with it and I wouldn’t use anything else. I especially love it’s ability to backup to dropbox. I recommend this to all my WordPress clients so they have an automatic offsite backup. I am well on my way to 8Gb of storage from my referrals. 🙂

    I have other installs on the same server (different cPanel accounts) and they are all working fine.

    The site that is giving me problems is a redevelopment of a currently active website. I have needed to set my local hosts file to access the site. I have been wondering if this is what may be causing the issue. The site should be live tomorrow so I can let you know if being accessible to the outside world fixes the problem.

    Darren, agree fully.

    Btw, to anyone reading this thread, I just removed all the custom paths for backup etc. Just leave the settings blank for most options. I only ticked off some “exclude” folders and that’s it.

    Now it’s backing up without any problems. And dropbox has a copy!


    Love this plugin. And darren, thanks for responding.

    You’re welcome. Glad you got it working. I hope tomorrow brings the same result for me.

    thanks Darren for the many help-

    You’re welcome Daniel. Thanks for the great plug-in.

    We moved the “problem” site live today and the backups are working perfectly. It looks like my problem was the site was only accessible by setting the local hosts file. As soon as the domains nameservers were pointed to the new site and the DNS propergated the backups worked.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: BackWPup] Backup does not run’ is closed to new replies.