WordPress.org

Support

Support » Plugins and Hacks » BackUpWordPress » [Plugin: BackUpWordPress] Stuck in "Removing old backups"

[Plugin: BackUpWordPress] Stuck in "Removing old backups"

  • Hello,

    first of all, thanks for this plugin 🙂 I have a problem though. I installed it, then immediately tried to run a manual backup, and it stucks in “removing old backups [cancel]”. Pressing the message to cancel it does nothing – the page reloads and the message is still there, along with the “loading” circle.

    I tried uninstalling, manually deleting the plugin and the backups folder via FTP, and re-installing. But the same still happens.

    Navigating via FTP to the backups folder, I have these files:
    .backup_complete
    .backup_running
    .backup_warnings
    .htaccess
    database_holoville_com_blog
    hoblog.backup.2012-05-14-12-03-22.zip
    hoblog.backup.2012-05-14-12-03-22.zip.a31156
    hoblog.backup.2012-05-14-12-03-22.zip.b31156
    pclzip-4fb0d88c32b14.tmp

    .backup_warning contains this text:

    {“php”:{“7d913f8cb3afc80651fa5dd0a51fc98b”:[2,”unlink(D:\/www\/MW_qPPPIaRIq\/holoville.com\/blog\/wp-content\/backups\/database_holoville_com_blog.sql): Permission denied”,”D:\\www\\MW_qPPPIaRIq\\holoville.com\\blog\\wp-content\\plugins\\backupwordpress\\hm-backup\\hm-backup.php”,396]}}

    (which seems to correspond to “unlink( $this->database_dump_filepath() );”)

    Thanks & a nice day,

    Daniele

    http://wordpress.org/extend/plugins/backupwordpress/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Tom Willmot

    @willmot

    Hi Daniel,

    Thanks for the report, it’s strange that your getting a permission denied warning deleting the database dump file as that file is written by the same script.

    Can you login via FTP and delete all the files in the backup folder and then try again.

    Hi Tom,

    thanks for the help.

    Just tried it, and deleted everything (htaccess included, which anyway was correctly recreated). Got the same exact error.

    Plugin Author Tom Willmot

    @willmot

    Well, thanks for trying.

    Could you log in Via FTP and check what the permissions are on both the backups folder and the database dump file itself, I’m interested to see what they have been written as.

    Uh, I’m sorry but it seems like I can’t see the permissions (tried various ways – might be I’m too ignorant to do it), but I can try to set them. What should they be?

    Plugin Author Tom Willmot

    @willmot

    The permissions on the backups directory should be 755 and on the database file itself 644

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: BackUpWordPress] Stuck in "Removing old backups"’ is closed to new replies.
Skip to toolbar