WordPress.org

Support

Support » Plugins and Hacks » BackUpWordPress » [Resolved] [Plugin: BackUpWordPress] Stuck in "Creating zip archive" mode

[Resolved] [Plugin: BackUpWordPress] Stuck in "Creating zip archive" mode

  • TheBigGroundhog

    @thebiggroundhog

    We are using WordPress 3.1 on a Windows platform. When I try to run BackupWordPress manually it shows “Creating zip archive” at the top of the screen but never completes.

    Files are created in the “C:\inetpub\wwwroot\wp-content\backups” directory which include:

    .backup_running
    .htaccess
    database_xx_wordpress.sql
    Blog.backup.2011-11-22-11-14-42.zip

    But I don’t see any other error message or additional logs. Any idea where to look for additional problem messages?

    http://wordpress.org/extend/plugins/backupwordpress/

Viewing 15 replies - 16 through 30 (of 43 total)
  • Plugin Author Tom Willmot

    @willmot

    Hi d00dahman,

    I’d love to know, did 1.5.1 fix the issue for you?

    I updated to version 1.5.1 and the manual full backup still hangs on “Creating Zip Archive”. As a test, I did a database only backup and that successfully worked, then tried to do a file only backup and that is where the backup is hanging.

    Are there more detailed logs anywhere to find out where it is getting stuck?

    Plugin Author Tom Willmot

    @willmot

    Thanks for reporting back, there aren’t any detailed logs, you could narrow it down by excluding some files, are there any unusual folders in root?

    I had this same issue using the latest bits.

    I also had an issue where the reported size of the backups kept going up and up.

    It seems that the backup was including its own backup folder, so it was trying to zip the zip file that it was creating.

    Once I excluded the backup directory it worked and the backup sized dropped like a rock.

    Note that I’m on a windows based shared hosting site, it may work differently under a normal unix based system.

    Okay, I think we’re getting closer. Here are some of my recent changes:

    1. Upgraded to the latest PHP version for Windows from the “Microsoft Web Platform Installer 3.0”. This seemed to make the backup complete, but caused multiple zip files to be created.

    2. Excluded the backups folder per comment by Segfaultcoredump. With Windows you have to put the full path to the directory so we have: c:/inetpub/wwwroot/wp-content/backups

    3. Install and use 7zip to test the created zip file. Windows kept considering the zip file to be corrupted (when you opened the zip file it was empty). When viewing from 7Zip the first directory is “C:” (with the colon) that I’m guessing the regular Windows zip tool doesn’t like.

    I’m going to do some more testing and turn on database backups again for an automatic backup.

    I am running 1.6 (bleeding) and everything seems to be working now. Should I back down to 1.5.1, or leave well enough alone?

    Hi
    I had the same problems.
    When I choose to backup Database only, it was ok.

    Plugin Author Tom Willmot

    @willmot

    agis775,

    It’s likely that you have some unreadable filess in your root dir which are breaking the file backup, the latest development version should fix the issue.

    I’ll release an update with the fix in a couple of days.

    Tom

    In order to exclude the folder: backup-2f027,
    is correct: /wp-content/backup-2f027/

    Thank you very much

    Plugin Author Tom Willmot

    @willmot

    Another rather large release, I’d love it if you could give it a go and see if it fixes your issues.

    Hi, Tom. It’s good to know about the update.

    Just updated the version I installed yesterday at a new website and at a another one I had from earlier. My findings:

    – The number of backups to keep is lost and returns to 10.
    – Backups failed. There are no new files at /wp-content/backups.
    – Emails were sent telling the backups finished OK, yet they didn’t.
    – Emails said the backup should be attached, yet they weren’t.
    – In every case, a warning was displayed at the end and it doesn’t go away and has no “hide” or “dismiss” link/button. I logged out and logged in again and it is still there 🙁

    The warning message in one case included each file in the directories I had excluded:

    BackUpWordPress detected that your last backup failed.
    
    zip: Backup file doesn't contain the the following files: wp-content/themes/twentyeleven/404.php, wp-content/themes/twentyeleven/...

    In the other case I had no excluded directories, yet one plugin returned errors:

    BackUpWordPress detected that your last backup failed.
    
    php: 8:Undefined index: solo-comment-subscribe:/home/AAAAAA/public_html/es/wp-content/plugins/subscribe-to-comments/subscribe-to-comments.php(852) : runtime-created function:1
    
    php: 8:Undefined variable: update:/home/AAAAAA/public_html/es/wp-content/plugins/subscribe-to-comments/subscribe-to-comments.php:731
    
    php: 8:Undefined index: default_subscribed:/home/AAAAAA/public_html/es/wp-content/plugins/subscribe-to-comments/subscribe-to-comments.php:266

    Hope this helps.
    Cheers.

    PS: A minor thing: note the repetition of “the” in the first warning message.

    Plugin Author Tom Willmot

    @willmot

    Thanks for the detailed response idearius, I’ll look into each of those issues and get back to you.

    You’re welcome. Just one more thing: the error message went away once I deleted the file “/wp-content/backups/.backup_errors”.

    Plugin Author Tom Willmot

    @willmot

    Yep, that file is where the errors are stored, it is auto deleted everytime you backup.

    My backup also fails since I updated to WP 3.3.1 and BackUpWordPress 1.6.1. I get the following:

    BackUpWordPress detected that your last backup failed.
    
    php: 8:Undefined index: sc_wpfmp_scan:/usr/share/wordpress/wp-content/wordpress-file-monitor-plus/wordpress-file-monitor-plus.php:84
    
    php: 8:Constant WP_POST_REVISIONS already defined:/usr/share/wordpress/wp-config.php:94
Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘[Resolved] [Plugin: BackUpWordPress] Stuck in "Creating zip archive" mode’ is closed to new replies.
Skip to toolbar