Support » Plugin: BackUpWordPress » [Plugin: BackUpWordPress] Got error: 1044: Access denied for user after upgrade

  • Resolved ntfreak

    (@ntfreak)


    Hi,

    I have just upgraded backupwordpress plugin from 1.31 to the latest 1.68 and get the above msg now.

    The actual files are fine it just fails to backup the database.
    For info i already have HMBKP_MYSQLDUMP_PATH set to false, and if i revert back to 1.31 all is ok with the database backup.

    Any help greatly appreciated.

    Many Thanks
    Spen

    http://wordpress.org/extend/plugins/backupwordpress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok i have solved the user as follows:
    The wordpress install is running on sourceforge, sf gives us 3 database user accounts with the following permissions:
    RO user: (SELECT)
    RW user: (SELECT, INSERT, DELETE, UPDATE)
    ADMIN user: (has RW account privileges, and CREATE, DROP, ALTER, INDEX, LOCK TABLES)

    For a year or so we have been using the rw user and this has been working fine for older versions of BackUpWordPress (1.31).

    Newer versions seemed to fail even though we had HMBKP_MYSQLDUMP_PATH set to false.

    Changing the user to admin has solved all the problems and is good enough for me.

    Cheers
    Spen

    Plugin Author Tom Willmot

    (@willmot)

    Thanks for the heads up re. the different users, I look into what I can do to resolve the issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: BackUpWordPress] Got error: 1044: Access denied for user after upgrade’ is closed to new replies.