Support » Plugin: BackUpWordPress » [Plugin: BackUpWordPress] E-mail attachments are not generated

  • Resolved Mark Cleveland



    • Ensure you have selected an e-mail address for delivery of backup files in the setting “Email backups”, and that the “What to backup” setting is set to “database”

    Site experiencing issue

    1. From the screen Tools > Backups, select Backup Now
    2. Check the email in question
    3. Observe there is reference to a file attachment that does not exist

    E-mail attachments are not generated. The e-mails are being generated fine, however the attachment of the relevant backup data is not working. The database size is about 360 kB.

    This issue does not occur on other site’s to which I have access.

    This issue also occurs regardless of the setting for “What to backup”. This issue also occurs after uninstalling the plugin and re-installing it using the Plugins directory.

    The issue was not reported to have occurred previously by the website’s owner. I noticed the issue after a recent update to version 1.6.2, after which the emails seemed to work, but the file size was too large to allow attachments. I later updated to version 1.6.3 to avoid a “duplicate headers” error, and have since noticed the issue. It is therefore entirely possible this occurred with previous versions of the plugin.

    The backups appear to be generated on the site’s webspace correctly – according to the Tools > Backups page and FTP directory listing, there are full backups being generated in the appropriate folder each time I select Backup Now. These are fully downloadable via FTP or the Tools > Backups page. These backups have not been tested to ensure they will successfully restore lost data.

    The site in question has the “W3 Total Cache” plugin installed. If the user selects to clear its page cache after each deactivation and subsequent reactivation (as recommended by its warnings when activating or deactivating a plugin), the issue still occurs.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Tom Willmot


    This has been fixed in 1.6.4

    I also have this issue. I’m running BackUpWordPress Version 1.6.4 and WordPress 3.3.1.
    Backups are generated in the folder and the email is being sent, but the attachment is missing. I tried all 3 settings in the “What to Backup” box, but none of them generated an email attachment. My DB file is 380KB, the complete file is at 12MB.

    Any hints on how to solve this?

    Btw: I just love this plugin. Getting the email thing to work would make this plugin super.

    This has been fixed in 1.6.4

    I have 1.6.4 installed. This issue still occurs as described.

    Any news on this? This would be the perfect backup plugin if the email attachments would work.

    Added Info
    This issue now occurs on other sites to which I have access.

    I also have the same issue on sites using version 1.6.4. There are no email limitations on attachment sizes on the servers or on the email accounts. BackupWordPress is correctly producing the backup files, sending the email correctly but NOT adding the attachment.

    Developers: I am almost positive the issue is GLOBAL. This feeling comes from the fact I have performed a fresh install of the BackupWordpress plugin on a clean WordPress 3.3.1 installation, and the issue still occurs. I have several clients wanting to know why their attachments aren’t being generated.

    Is this a funding problem? What’s the deal? 3 weeks and all I see so far (besides others with the same issue) is a single response that is incorrect.

    Plugin Author Tom Willmot


    Hi Mark,

    Thanks for adding your voice to the mix, it does seem like there is an issue with attachments in the latest version.

    It’s a time issue more than anything, we’re all super busy working, we try and put as much time into BackUpWordPress as we can, but obviously we can’t all work on it all the time, we have to do client work as well 🙂

    The plugin is hosted on Github, your more than welcome to take a stab and finding and fixing the issue if you can / want to, if you do send me a pull request and I’ll include it.

    Thanks for the link, however I see why you can’t find the issue quickly. You (and I as well) would need more information.

    There were numerous structure changes made in the logic within that backup.functions.php over the past 4 weeks (actually ..just in the email_backup function alone!). And would help to know if my report was truly the first on this issue (or just know the exact date it started occurring). If only I could tell the exact date of my report.. (I don’t get an email update when I post, only when someone replies..and I don’t see an exact time/date stamp on this forum that gets around that).

    Solution: Anyways, the only way to begin going about such a task (me being tester, and developer ..sigh) without the exact date, would be to have all the builds of the plugin from the dates surrounding 1/1/12, then test them each one-by-one until I find the last one that worked, and then I could go in and see what changed by comparing the files that were edited around the time that build was released.

    Verdict: Give me more info, and I will take a look for you. Otherwise, me trying to do what you propose, is like fumbling around in the dark looking for a needle in a hundred haystacks.

    🙂 Regards.

    Actually; is this where it is believed the first occurrence began?? Or just the first one with a bug report?

    And this seems possibly related to the issue as well.. (same time frame, and definitely related to the backup file’s creation) though it was closed.

    Plugin Author Tom Willmot


    Your best bet is going to be to fork the project and then clone it locally.

    The code you want to debug is in backup.functions.php.

    It appears you might have missed the preceding post, sir.

    The second most recent post (before your own most recent) refers to that very file…and needing more information to track down when the issue occurs. And the most recent post asks for clarification.

    Plugin Author Tom Willmot


    Unfortunately I don’t know when the issue occurs. You could look through the github commit log for changes to the file.

    In backup.functions.php

    after line 126, insert:

    $file = HM_Backup::get_instance()->archive_filepath();

    This works for me. I now get the backup correctly attached to the email. It seems that the $file variable was not set (or the setting of it got removed somewhere, I did not go through the commit log)

    Hope this helps.

    I forgot to mention that my modification is for 1.6.4

    Looking at the commits on github, it looks like this was fixed in the last commit for backup.functions.php on 14/1/2012, but hasn’t been released yet.

    So I suspect that you can grab the latest from github and it will work (i have not tested this). Or you can make the change to 1.6.4 above.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: BackUpWordPress] E-mail attachments are not generated’ is closed to new replies.