Support » Plugin: BackUpWordPress » [Plugin: BackUpWordPress] Backup Time Appears to be Current Time

  • Just updated from v1.6.9 to v2.0.1 and noticed on the Manage Backups screen (Tools, Backups) where it says “Backup my ?? MB database and files daily at <time>” that the time always appears to be the current time, and not the expected 11 pm.

    It also appears that the help no longer lists the HMBKP_DAILY_SCHEDULE_TIME constant.

    http://wordpress.org/extend/plugins/backupwordpress/

Viewing 15 replies - 1 through 15 (of 23 total)
  • I updated yesterday from 2.0 to 2.0.1, the automatic backup did not run this morning, so I ran it manually. If I save the settings, then backuptime becomes current time. Where can I set the backup time I want?

    I too am running version 2.0.1 and now find that the backup time is scheduled for the time I access > Tools > Backups.

    How can this be changed?

    Same issue here.

    In my case the automatic backup also is not working, after updating. The time is set but no backup or email. Manual backup works.

    Same here (both about the automatic backup and the backup time “auto-setting”).

    Plugin Author Tom Willmot

    (@willmot)

    Both these issues have been fixed in 2.0.3

    New schedules will again default to 11pm and automatic backups are now working again.

    I’ll bring back the ability to control the schedule time in a future update.

    Just updated to v2.0.3 and the behavior does not appear to have changed, on the “Manage Backups” page. The page does not update the “calculating the size of your site…” field and the time field always displays the current time.

    Backup my <calculating the size of your site…> database and files daily at <9:33 am>, store only the last 10 backups on this server.

    Going back to v1.6.9 again.

    Plugin Author Tom Willmot

    (@willmot)

    Thanks for taking the time to test.

    For the backup time, you’ll need to re-add the schedule to get the 11pm time.

    For the calculating backup size issue, are there any js errors on the page, it should pull in the size via ajax.

    No apparent JavaScript errors when bringing up the Manage Backups page </wp-admin/tools.php?page=backupwordpress>.

    I’m not seeing anything unusual within Chrome’s Developer Tools window.

    The “+ add schedule” doesn’t appear to work for me. Clicking it </wp-admin/admin-ajax.php?action=hmbkp_add_schedule_load> changes to a page with just the “Schedule Settings” box; the WordPress menus go away. Clicking the “Update” button on this page doesn’t appear to do anything. No new schedule listed when I navigate back to the Manage Backups page.

    Comment on the Schedule drop down box: it would be nice if the selections in this dropdown were ordered by frequency, instead of jumping from “Once Monthly” to “Once Daily” in the middle of the list.

    Plugin Author Tom Willmot

    (@willmot)

    Hmm, that deff sounds like the JS isn’t working as all those actions rely on JS.

    In chrome dev tools could you verify that the js is being loaded (the file is hmbkp.js).

    It loads hmbkp.js in v1.6.9, but does not in v2.0.3.

    Plugin Author Tom Willmot

    (@willmot)

    Ah that will be the issue then.

    Using the developer tools can you tell whether it’s because the url to the hmbkp.js file is incorrect? Could you paste the url it’s trying to load here?

    I’m wondering if the code that generates the url changed between those versions and has thus broken for you.

    There aren’t any errors. I simply don’t see hmbkp.js load with v2.0.3, like I do with v1.6.9 (URL below).

    /wp-content/plugins/backupwordpress/assets/hmbkp.js?ver=3.4.2

    What should trigger the load of hmbkp.js?

    Plugin Author Tom Willmot

    (@willmot)

    The script is enqueued using wp_enqueue_script.

    If you use the resource tab of chrome dev tools and then reload the page, do you see hmbkp.js in there (maybe as a 404?)

    It doesn’t come up in the Chrome DevTools Resources tab, and there’s no apparent error.

    I see a reference in tools.php that should load it, but with v2.0.3 these lines are really wierd:

    <script type=’text/javascript’ src=’http://wcBacterialPhysiologists.ucdavis.eduE:WebSiteswcBacterialPhysiologists.ucdavis.eduwp-contentpluginsbackupwordpress/assets/fancyBox/source/jquery.fancybox.js?ver=2.0.3′></script>
    <script type=’text/javascript’ src=’http://wcBacterialPhysiologists.ucdavis.eduE:WebSiteswcBacterialPhysiologists.ucdavis.eduwp-contentpluginsbackupwordpress/assets/hmbkp.js?ver=2.0.3′></script>

    In v1.6.9 the line looks like this:

    <script type=’text/javascript’ src=’http://wcBacterialPhysiologists.ucdavis.edu/wp-content/plugins/backupwordpress/assets/hmbkp.js?ver=3.4.2′></script>

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: BackUpWordPress] Backup Time Appears to be Current Time’ is closed to new replies.