Support » Plugin: BackUpWordPress » [Plugin: BackUpWordPress] 2.0.1 update – conflict with Shopp plugin

  • Resolved katew3630

    (@katew3630)


    Upgraded to 2.0.1 and didn’t notice a problem until I had to update products in my Shop (using plugin from https://shopplugin.net/) – I couldn’t update certain fields in the product area & if I could, it threw up a warning.

    I tracked it down to the BackUpWordpress plugin by deactivating all plugins & reactivating one by one.

    It seems like a memory error in Shopp – searching for products throws up this warning:

    Warning: Invalid argument supplied for foreach() in /home/hoads231/public_html/testsite/wp-content/plugins/shopp/core/model/Product.php on line 203

    Going into edit a product from the search list, the page doesn’t finish loading – images aren’t editable and pricing area shows a spinning wheel.

    Going into the product edit page via category filter, the whole page does load and I am able to make an edit and save but these lines appear:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/hoads231/public_html/testsite/wp-content/plugins/shopp/core/flow/Warehouse.php on line 492

    Warning: join() [function.join]: Invalid arguments passed in /home/hoads231/public_html/testsite/wp-content/plugins/shopp/core/flow/Warehouse.php on line 492

    When I deactivate the BackUpWordPress plugin, these issues disappear.

    Any ideas? I have posted in the Shopp forum as well.
    Thanks.

    http://wordpress.org/extend/plugins/backupwordpress/

Viewing 1 replies (of 1 total)
  • Plugin Author Tom Willmot

    (@willmot)

    Unfortunately I don’t have a copy of the Shopp plugin so I can’t test this.

    I’d recommend reaching out to the Shopp developer as the errors are in his code,

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: BackUpWordPress] 2.0.1 update – conflict with Shopp plugin’ is closed to new replies.