The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Backup Guard
[Plugin: Backup] The Authentication does not work - Bad response! (8 posts)

  1. tomasz1976
    Posted 4 years ago #

    I think, this will be one of the most usefull plugins I ever seen.
    BUT, first I must to make it work.
    For some reason the authentication gives me a Bad response! message.
    Any Idea what can cause it, or what should i do?



  2. feytus
    Posted 4 years ago #

    I got this message when trying to backup yesterday. I just copied and pasted the Client ID and Secret again, and it worked. So just try to re-do it, maybe it'll work for you. :)

  3. tomasz1976
    Posted 4 years ago #

    Hi feytus.
    Thanks, but did try it many times yesterday and today too. No result :(

  4. iclanzan
    Posted 4 years ago #

    Szia tomasz,

    Can you please post the relevant lines from backup.log here?

    From the top of my head I can think of a few possible problems. For example did you register the redirect URI on the Google APIs Console when you created the Client ID and client secret?

    Also you could try the latest version of the plugin.

  5. Neoced
    Posted 4 years ago #

    Hello, sorry but... where can I create Client ID and client secret for Google Drive ? With Google Drive console ? With sharing option ?

  6. iclanzan
    Posted 4 years ago #

    Hi Neoced,

    You need to create the Client ID and secret from the Google APIs Console. Read the contextual help from inside the plugin settings page for more info.

  7. tomasz1976
    Posted 4 years ago #

    Szia Helio,

    the authentication works now, or I think so. Whenever I click to "Authorize" and after on redirected google page the "Allow access" everything seams to be all right, but after I get the following message back on my WP dashboard:

    Authorization failed!
    Operation timed out after 5000 milliseconds with 0 bytes received

    Why is that?

  8. theoneinpink
    Posted 3 years ago #

    Hi all, I had trouble authenticating with Google Drive as well. It is pretty simple though.

    In the settings, click "Need help?" then click "Authorization." There is a URL in here that you will need to copy. Then click through to the Google API Console (there is a link.)

    Create a Google API client ID if you don't already have one. It will ask you for a product name (whatever you want) and a Google account (which you should have).

    Click next through the steps. You will get to the point where it will ask you for authorized redirect URLs. You need to paste that URL you copied in here, but remove the s from the https:// - it did not work for me until I removed the s. It will generate a Client ID and Client secret which you can copy & paste into the Settings area of the backup plugin.

    As soon as I did this it worked fine and my Google account showed up inside the plugin settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.