Support » Plugin: Background Manager » [Plugin: Background Manager] Background per page don't work

  • Resolved erspoelstra

    (@erspoelstra)


    I installed everything as instructed, but the background per page don’t work. I get the same background on every page, although I set the background on the page to a different image set.

    When I look in the source of that page, I see that the wrong current_background is selected:

    /* <![CDATA[ */
    var myatu_bgm = {"current_background":{"id":409, "url":"http:\/\/xxxxxxx\/wp-content\/uploads\/2012\/06\/25870990-groot.jpg","alt":"","desc":"", "caption":"25870990-groot","link":"","thumb":"http:\/\/xxxxx\/wp-content\/uploads\/2012\/06\/25870990-groot-150x150.jpg","bg_link":"","transition":"crossfade", "transition_speed":0},"change_freq":"0","active_gallery":"408","is_fullsize":"true","is_preview":"false", "initial_ease_in":"false","info_tab_thumb":"true","bg_click_new_window":"false","bg_track_clicks":"false", "bg_track_clicks_category":"Background Manager","fs_center":"true"};
    /* ]]> */

    The active gallery is 408 but should be 410 (according to the custom field on the page (myatu_bgm_active_gallery).

    Can you please help me with this issue?

    http://wordpress.org/extend/plugins/background-manager/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Oh, and by the way, the overlay is working per page (I get different overlays, but with the same background everywhere)

    We are having the same issue since updating to BM 1.1 and WP 3.4 “Green” this morning.

    Update:
    We tried reverting to the older plugin (BM 1.0.25) but this does not work either because then no background shows up at all. Apparently something has changed in the database. Reverting not recommended.
    ~C

    Exactly the same issue here.

    Waiting for a workaround or solution, its holding up my project at the moment.

    Thanks in advance.

    http://wordpress.org/extend/plugins/background-manager/

    Plugin Author myatu

    (@myatu)

    Hi!

    Yes, this is a bug that managed to make its way past the last tests and I’m uploading a fix as I’m writing this (version 1.1.1). My apologies!

    Thank you for the quick fix, I downloaded the fix and everything seems to be working fine!

    If its working for the others, this topic can be marked as ‘resolved’.

    Thanks for the quick fix, everything is working fine again here too!

    Fantastic! Thanks for the fast fix.
    All is working well now. 🙂

    Plugin Author myatu

    (@myatu)

    Glad to hear it’s fixed. Sorry about that!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Background Manager] Background per page don't work’ is closed to new replies.