Support » Plugins » [Plugin: AVH First Defense Against Spam] AVH Breaks multi site on wordpress 3.0 RC1 and nightly buil

Viewing 5 replies - 1 through 5 (of 5 total)
  • I just did a test on my local machine and it works fine.
    The only plugin I have active is AVH First Defense Against Spam. It’s network activated.

    WordPress 3.0 multisite
    Sites as subdomain, so newsite.mainsite.tld

    So on my test installation, I discovered that AVH First Defense Against Spam breaks multisite on WordPress 3.1

    The key difference from petervanderdoes is that my sites are set up as subdirectories, so http://www.mainsite.tld/newsite

    When I create a new site when AVH FDAS is installed, the link to its site-specific Dashboard in the network admin Sites listing is: http://www.mainsite.tld/wp-admin instead of http://www.mainsite.tld/newsite/wp-admin

    Also, I get the “Error establishing a database connection” error when trying to directly access http://www.mainsite.tld/newsite/
    The site-specific Visit link from the network admin Sites listing is http://www.mainsite.tld/wp-admin/network/sites.php

    If I disable AVH FDAS, then create a site in my network, and re-enable AVH FDAS, things seem to work fine. I would suspect that this plug-in only interferes with the site creation process.

    I’m on the verge of releasing an updated version of the plugin. This problem won’t be addressed in it but instead of delaying the new release I’ll see if I can fix it after the new release.

    This should be fixed in version 3.1.1

    Peter,

    The issues that I mentioned in my earlier post no longer occur with new subdirectory sites after I applied the 3.1.1 update to AVH FDAS. All seems to work as intended. Thank you for the update.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: AVH First Defense Against Spam] AVH Breaks multi site on wordpress 3.0 RC1 and nightly buil’ is closed to new replies.