Support » Fixing WordPress » [Plugin: Autoptimize] Cuts Out Ads

Viewing 7 replies - 1 through 7 (of 7 total)
  • Until the next version goes out, replace the “autoptimizeScripts.php” file you have in your WordPress installation with this one (the file is in wp-content/plugins/autoptimize/classes/):

    http://svn.wp-plugins.org/autoptimize/trunk/classes/autoptimizeScripts.php

    The problem you experienced was caused by Autoptimize not knowing the fastclick and amazon scripts needed special treatment, the next version will include them in the ‘do not move list’ and will work fine out of the box.

    If you experience any other issue do not hesitate to ask! 🙂

    (BTW, If it’s just the ads dissapearing or some script breaking, you can just disable the Javascript optimizations and leave all the others on, leaving the site half-optimized)

    One more issue:

    In our comments at http://www.macnightowl.com, we see the space between the avatar and the commenter’s name is eliminated when your plugin is active. Any way to fix/compensate for that?

    Peace,
    Gene

    Add something like this to the theme’s css code:

    .avatar {
    margin-right:5px;
    }

    That should add a space between the image and the name.

    Great. We’re getting there. I’m having a problem with one ad in one of our forums, which won’t display with your plugin enabled, but it’s more complicated than I dare discuss here.

    Maybe we can take this privately (write me through my site’s Contact Us menu) and I’ll explain in more detail, if you have the time to deal with it.

    Peace,
    Gene

    I have just written to you using the contact form. Looking forward to receiving a reply.

    Thank you.

    I look forward to working with you to resolve this and make your plugin better for everyone. 🙂

    Peace,
    Gene

    If you are using Google ad manager add the following to the $dontmove array in this the file above

    'google_service.js','GS_googleAddAdSenseService','GS_googleEnableAllServices','GA_googleAddSlot','GA_googleFetchAds','GA_googleFillSlot',

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Autoptimize] Cuts Out Ads’ is closed to new replies.