WordPress.org

Forums

AutoNav Graphical Navigation and Gallery Plugin
[resolved] List Titles Always on Top (8 posts)

  1. cwendt01
    Member
    Posted 3 years ago #

    In the shortcode, when I set display="list,thumb,title" the title is always displayed above the thumbnail image, even when I also include titles="1" and click the checkbox for it on the plugin's settings page.

    It works correctly when in table mode, but I'd much prefer the pages to use lists, not tables. How do I fix this?

    http://wordpress.org/extend/plugins/autonav/

  2. wlindley
    Member
    Plugin Author

    Posted 2 years ago #

    So... in list mode, you want what output exactly? Example please

  3. cwendt01
    Member
    Posted 2 years ago #

    Preferably this:

    [ul]
    [li][a href=""][img src=""][br]Page Title w/ Link[/a][/li]
    [li][a href=""][img src=""][br]Page Title w/ Link[/a][/li]
    [li][a href=""][img src=""][br]Page Title w/ Link[/a][/li]
    [li class="last"][a href=""][img src=""][br]Page Title w/ Link[/a][/li]
    [/ul]

    I can make a screenshot if that'd help, but the above is basically what I want. The current "list" setting does near exact that, but the title is always ABOVE the image, where I need it BELOW the image.

    Thanks for your response!

  4. wlindley
    Member
    Plugin Author

    Posted 2 years ago #

    The current plugin is relatively fixed in what it does. You could patch the file autonav-wl.php, by modifying the function an_create_output_table_picture to print what you want. Naturally, updating the plugin later would overwrite your changes.

    Version 1.5.0 of the plugin, still in development, will be much more flexible about output.

  5. wlindley
    Member
    Plugin Author

    Posted 2 years ago #

    This is what the version 1.5.0 readme.txt will recommend you do. Note, this does not work with the current version!

    For example, if you wanted to have list items add the picture first, and then the text, you could override the default order, and have the built-in AutoNav functions called in a different order. Put this in your theme's functions.php:

    remove_all_filters('autonav_create_list_item');
        add_filter('autonav_create_list_item', 'an_create_output_picture', 10, 4);
        add_filter('autonav_create_list_item', 'an_create_output_text', 15, 4);
        add_filter('autonav_create_list_item', 'an_create_output_excerpt', 20, 4);
  6. cwendt01
    Member
    Posted 2 years ago #

    Actually, I ended up going into the autonav-wl.php just like you suggested and was able to just switch some of the lines around to get exactly what I wanted!

    I'm looking forward to the next version of this plugin. It has been hugely instrumental in the 3 websites I'm currently coding and has saved me unimaginable amounts of time I would've otherwise spent on populating and proofing, so I owe you a huge THANK YOU! :)

    Also, thanks so much for replying to my thread with answers. Greatly appreciated!!

  7. wlindley
    Member
    Plugin Author

    Posted 2 years ago #

    Splendid! If you wish to try a beta-test of the new version, perhaps on a separate WP install, you may download it here. If you do -- please let me know whether it works for you.

  8. cwendt01
    Member
    Posted 2 years ago #

    Ooh, I'll have to check into it sometime. I've already implemented AutoNav on all my sites that need it at the moment, but I'll keep it in mind if something new comes up. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags