Support » Plugin: AutoNav Graphical Navigation and Gallery Plugin » [Plugin: AutoNav Graphical Navigation and Gallery Plugin] AutoNav 1.49a not showing NextGEN gallery

  • Resolved billmilosz

    (@billmilosz)


    I’ve got AutoNav 1.49a installed. I am trying out the NextGEN Gallery plugin, which is the most popular gallery in the WordPress world, and one of the most popular plugins period.

    The AutoNav changelog says,
    “New filters for extensions like NextGEN Gallery thumbnail support, and for taxonomy-images plugin. These are then implemented in auxiliary plugins, or theme files.”

    So, how exactly do I get AutoNav to display thumbnails from NextGEN galleries? Where is this “auxilliary plugin” you mention, does it exist?

    http://wordpress.org/extend/plugins/autonav/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wlindley

    (@wlindley)

    The auxiliary plugins are in the addons.zip file. Move the plugin you want (autonav-nextgen.php) into the same directory as autonav-wl.php and enable it.

    (I have tried several other ways of distributing addons but they all either cluttered the admin screen or made the main plugin fail to install. Suggestions appreciated.)

    Plugin Author wlindley

    (@wlindley)

    One disadvantage to NextGEN is that it does not support multiple arbitrary size thumbnails and resized images. AutoNav will be limited to using only the sizes that NextGEN creates, for images drawn from their gallery.

    OK so I put autonav-nextgen.php in the same folder with autonav-wl.php (ver 1.4.9b ) and then ‘Autonav NextGEN Thumbnail integration’ shows up in my plugins list; I activated it.

    However Autonav is NOT generating a thumbnail / navigation link for NextGEN galleries that are in the sub-pages of the page where I have the [autonav display=”images” pics_only=”1″] shortcode

    Ordinary galleries appear as Autonav thmubs, but not the NextGEN galleries.

    ???

    Plugin Author wlindley

    (@wlindley)

    Please email me and let’s see if we can debug this on your system.

    Plugin Author wlindley

    (@wlindley)

    The primary issue was that merely calling [autonav] inside a child page, does not set that child page’s featured image (thumbnail). You have to explicitly specify the featured image in the WordPress page editor.

    I see, the issue was I didn’t have the argument display=”images” pics_only=”1″ in the quickcode. OK. Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: AutoNav Graphical Navigation and Gallery Plugin] AutoNav 1.49a not showing NextGEN gallery’ is closed to new replies.