Support » Plugin: Auto ThickBox Plus » [Plugin: Auto ThickBox Plus] Thickbox simply stoped working

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have checked your faw:

    1. Can you see the HTML source codes bellow in your blog?

    Inside the <head> tag:

    <link rel=’stylesheet’ id=’thickbox-css’ href=’’ type=’text/css’ media=’all’ />
    Inside the <head> tag or before the closing </body> tag:

    <script type=’text/javascript’ src=’’></script>
    If you cannot see these tags, you may need to modify theme files because some WordPress themes do not output proper header/footer.

    And if you see duplicate <link href=”thickbox.css” /> or <script src=”thickbox.js”> tags, you may need to modify theme files or other plugins to avoid confict with this plugin because some WordPress themes and plugins output these tags in a wrong way.

    For instance, Events Calendar plugin outputs <link href=”thickbox.css” /> tag directly without calling WordPress function. As a result, improved thickbox.css has been overwritten with built-in thickbox.css, then ThickBox window layout has broken.

    2. Can you see class=”thickbox” attribute in tag?

    This plugin sets class=”thickbox” attribute to links to images automatically. So tags like below must have class=”thickbox” attribute.

    <img src=”image_s.png” alt=”foo” />

    3. Try to use built-in ThickBox resources

    Access ‘Options’ page, and check [ThickBox Resources – Use WordPress built-in thickbox.js/css] option. If ThickBox will work, there will be issues in Auto ThickBox Plus.

    1. seems fine
    2. no
    3. tried, doesn’t work.

    I know my theme is compatible with your plugin. I have been using both for more than 3 months. And nothing happened before. I am sure this happened after latest update, but I reckon this might be due to something else. Other plugins have upgraded too, but I just noticed it after you and jetpack updated. Please, give me some answer here.

    btw I was using 1.7, now I have undergraded it to 1.6 to see if this could work, but na…

    Plugin Author attosoft


    Hi fredgorski,

    I deeply apologize for this late reply.
    I’m currently developing another plugin.

    I found JavaScript error has occurred in your site. So in your site, some plugins using JavaScript, including Auto ThickBox Plus, won’t work.

    Auto ThickBox Plus does not work

    Most likely, some sort of JavaScript error has occurred in your blog. Please make sure that you can see any messages (errors/warnings) in browser console.

    If JavaScript errors have occurred, ThickBox may not work even when loaded properly.

    @attosoft thanks for your response.

    Actually, if you look this post
    you will see thickbox working normally. I see javascript error ocurring with plusone from google. I am not an expert, but I think the error is not ocurring on page load, but on the backend, cause class thickbox is not being set on the last posts…

    Plugin Author attosoft


    One of “last posts” is, for instance, this page? I can see several thumbnails in this page. They are linked to pages not images, but ThickBox is applied to links to images not pages.

    FYI: The JavaScript error that I found is as follows.

    Uncaught SyntaxError: Unexpected token < /heliconia-angusta-heliconia-vermelha/:698

    This error has caused by the following code at /heliconia-angusta-heliconia-vermelha/:698. That is the error has occurred when loading page.

    <p><!-- Posicione esta tag depois da ultima tag do selo. -->
    <script type="text/javascript">
      window.___gcfg = {lang: 'pt-BR'};</p>
    <p>  (function() {
        var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
        po.src = '';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);

    You can write only JavaScript code in <script> tag. But you’ll see </p> and <p> tags in it. These tags are HTML code so you must remove them.

    Yes, for instance the page you mentioned. The second code I have seen it when debugging it, but can’t figure out how it appeared there. I will contact people to help me on that. Thank u very much

    Plugin Author attosoft


    1. ThickBox does not work at some pages

    I guess you inserted images into pages with “Upload/Insert” link at Edit screen, and “Attachment Post URL” is set at “Link URL” option. To use ThickBox, you need to click “File URL” button to link the image to its original size version.

    * Ref. Inserting Images into Posts and Pages « WordPress Codex.

    2. JavaScript error by Google+1

    Open Dashboard and move to “Appearance – Widgets” page. You can find “Estamos no Google+” widget at “Main Sidebar – Text”. Then remove <p> and </p> tags and uncheck “Automatically add paragraphs” checkbox.

    Thanks again. I think problem is partially solved. I went to see the widget you mentioned, it had no tags, and the “automatically…” checkbox was not checked. I think this may be a bug, or whatever. Thank you anyway I will correct the links as you told me.
    I really appreciate your help.

    Plugin Author attosoft


    2. JavaScript error by Google+1

    This is not ThickBox issue. I think you use WP-Clear theme that is not free. So I recommend to use theme support.

    I am sorry, I think I didn’t make my self enough clear. I was not asking for your help further on this matter. I wanted to say anything concerning auto thickbox was solved and for the rest I would seek for help of others (including theme support) or anyone else in the world but not this forum. And I thank you for your patience in pointing the problems, which is really something not always usual with plugin developers. I have also quoted your plugin a 5 star. So, please, don’t be mad at me.

    Plugin Author attosoft


    Thank you to rate the plugin.
    I’m sorry that I don’t know the cause of JavaScript error. Frankly to say, I can hardly advise you anymore.
    Hope your problem will be resolved soon.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Auto ThickBox Plus] Thickbox simply stoped working’ is closed to new replies.