WordPress.org

Support

Support » Plugins and Hacks » Auto ThickBox Plus » [Resolved] [Plugin: Auto ThickBox Plus] ATP Not Working Properly For Me

[Resolved] [Plugin: Auto ThickBox Plus] ATP Not Working Properly For Me

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author attosoft

    @attosoft

    Hi lcp2000,

    Thank you for using Auto ThickBox Plus.

    What is the WP mode?

    I clicked YouTube and image links in your site, and ThickBox seems to work properly for me. Could you tell me how ThickBox does not work properly for you?

    Then I found you use built-in thickbox.js/css in your blog. Note that some extra features will be disabled when using them.

    Then I found you use built-in thickbox.js/css in your blog. Note that some extra features will be disabled when using them.

    Hi, sorry, that’s what I meant. I am using built-in thickbox by enabling the tick-mark on the setting: Use WordPress built-in thickbox.js/css (some extra features will be disabled), otherwise it will not work.

    I’ve un-ticked the setting so you can see what I mean. Click on the links now and you won’t get the thickbox. thx.

    http://werewolfwinter.com

    Plugin Author attosoft

    @attosoft

    I understand. Sometimes ThickBox does not work at all in your site.

    It is caused by some or one of widgets in the sidebar. I think scripts in your site won’t work until all widgets are displayed.

    BTW “Commont Tags” is too heavy for me, CPU usage will be about 100% while displaying it.

    BTW “Commont Tags” is too heavy for me, CPU usage will be about 100% while displaying it.

    Thx, I was trying it out but can’t really benefit from it at this time.

    I’ll also try disabling some of the other plugins to see if I can find the fault ang go from there.

    Plugin Author attosoft

    @attosoft

    I think the problem will be resolved by selecting “ThickBox Resources – Footer” option.

    Why built-in ThickBox in WordPress works while improved ThickBox in the plugin does not? The answer is load order of scripts.

    The load order of scripts in your site is as follows by default.

    1. Sidebar widgets
    2. Improved ThickBox in the plugin

    Then the load order is as follows when you use built-in ThickBox.

    1. Built-in ThickBox in WordPress
    2. Sidebar widgets

    That is why built-in ThickBox works, but improved ThickBox won’t work until widgets loading is complete.

    I think the problem will be resolved by selecting “ThickBox Resources – Footer” option.

    Yay! that did it…

    I thought about trying that option earlier but for some reason I just kept ignoring it. 😉

    Thanks for all your help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Auto ThickBox Plus] ATP Not Working Properly For Me’ is closed to new replies.
Skip to toolbar