WordPress.org

Forums

Auto Post Thumbnail
Probs w/ special characters, WordPress sites (1 post)

  1. lmhut
    Member
    Posted 3 years ago #

    Hi,

    I'm using Auto Post Thumbnail v.3.2.3 to generate thumbnails for posts I'm syndicating from FeedWordPress -- all of my posts come from external sources.

    The setup works pretty well, but I've noted a few instances where the thumbnail isn't working or wasn't fetched at all:
    1. When a special character (even a space) is in the image name
    2. Some WordPress sources (but others work OK, not sure why...)

    Some examples of the first problem:
    My URL: http://athensi.lmhut.com/category/news/ and http://athensi.lmhut.com/category/culture/

    Broken thumbnails (as of the time of this post) include:
    a. http://athensi.lmhut.com/wp-content/uploads/2011/11/mashmoor%201-50x50.jpg (source: http://woub.org/sites/default/files/styles/large/public/mashmoor%201.jpg)
    b. http://athensi.lmhut.com/wp-content/uploads/2011/11/Athens%20Co_Sheriff-badge-50x50.jpg (source: http://woub.org/sites/default/files/styles/large/public/Athens%20Co_Sheriff-badge.jpg)
    c. http://athensi.lmhut.com/wp-content/uploads/2011/11/Todd%20Grether-50x50.jpg (source: http://woub.org/sites/default/files/styles/large/public/Todd%20Grether.jpg)
    d. http://athensi.lmhut.com/wp-content/uploads/2011/11/art35273t3.jpg
    (source: http://www.athensnews.com/ohio/imgs/media.images/1524/ashgirl.nar.jpg)
    ...and many others.

    Some examples of the second problem (no thumbnail at all)
    a. On http://athensi.lmhut.com/category/culture/, "Bobcats edge Owls in an instant classic (speakeasymag.com)" should have thumbnail from source http://speakeasymag.com/wp-content/uploads/2011/11/Dontes-300x200.jpg
    b. On http://athensi.lmhut.com/category/blogs/, "Pete Oen Talks About His Stand-Out Congress (The Barrel Racing Blog)" should have thumbnail from http://thebarrelracingblog.files.wordpress.com/2011/11/391625_2261289255887_1358117259_32331010_362679899_n.jpg?w=300&h=225
    c. On http://athensi.lmhut.com/category/food/, "Late October Baking (Pizza Goon)" should have thumbnail from http://pizzagoon.com/wp-content/uploads/2011/10/oct-2011-144ii1.jpg

    This is a wonderful plugin that's allowing me to do something unique and highly automated with our website. It would be perfect if not for the issues above.

    Thanks for your support and hard work. I look forward to any solutions you might offer. Let me know if there's any other information I can provide to help troubleshoot this issue.

    --Lauren

    http://wordpress.org/extend/plugins/auto-post-thumbnail/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic