WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Auto Post Images (API)] "This plugin does not have a valid header"

[Resolved] [Plugin: Auto Post Images (API)] "This plugin does not have a valid header"

  • Plugin version: 3.0.1

    When activating this plugin I got a “This plugin does not have a valid header.”

    This might only happen on certain server configurations. Some server set-ups are ‘picky’ about how the PHP tag is opened is my experience, and it will need a lowercase full opening to work properly.*

    In auto-post-images.php in the plugin folder changing the uppercase PHP:

    <?PHP
    /*
    Plugin Name: Auto Post Images (API)

    to lowercase php:

    <?php
    /*
    Plugin Name: Auto Post Images (API)

    Fixes it.

    *See also ‘short_open_tag’:
    Description of core php.ini directives on php.net
    and ‘Example #2 PHP Opening and Closing Tags’:
    Escaping from HTML on php.net

  • The topic ‘[Resolved] [Plugin: Auto Post Images (API)] "This plugin does not have a valid header"’ is closed to new replies.