WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Auto Attachments] Not displaying file-type icons, & enable only on certain pages?

[Resolved] [Plugin: Auto Attachments] Not displaying file-type icons, & enable only on certain pages?

  • Tevya
    Participant

    @thefiddler

    Hi, I’m trying this plugin out, but unlike the screenshots and description, it is not displaying the nice icons you have for the various file types. I have several PDF’s attached to a page, and it is only showing a tiny diskette with a down arrow icon next to all of them. It’s a Multisite install, so maybe that has something to do with it? Screenshot: http://goo.gl/Vns3s

    There’s also a broken image in the admin interface: http://goo.gl/Uk6UK

    Also, it would be really nice if there were a way to enable only on specific pages/posts. So you can “turn all off by default” in the admin, then either a shortcode to insert anywhere on a page/post, or a checkbox to “include attachments on this page.” Thanks.

    http://wordpress.org/extend/plugins/auto-attachments/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Tevya
    Participant

    @thefiddler

    Also, it would be nice if the headings didn’t show up on pages/posts where there are no files listed. It looks funny just having that hanging out at the bottom of a page, with nothing below it.

    Plugin Author Serkan Algur
    Member

    @kaisercrazy

    Hi Tevya,

    I’m working on new version of Plugin and i will change lots of things with new version. The broken image thing about the timthumb. Timthumb will be deleted an plugin will use wordpress’ image crop, colorbox will be changed into lightbox like javascript.

    Also Tiny diskette thing about listing option. In Misc. Settings, if you set yes to List View Of Files, plugin will show your files as multi column list. And diskettes are list backgrounds.

    With 0.5.6 we solved empty headers issue. I Think no header will be shown if your page has no attachment(s).

    I’m working on a metabox also for selectable insert.

    Tevya
    Participant

    @thefiddler

    Great to hear you’re updating. It I was getting the header, when there were no attachments. So it just said “Files” (or whatever header I put) then there was nothing beneath it.

    ON the tiny diskette’s: so how do I get it to show the nice large filetype-specific icons shown in the screenshots for the plugin?

    Plugin Author Serkan Algur
    Member

    @kaisercrazy

    Hi again,

    Yeap, plugins core will change a little with 0.6. I give you screenshot about diskettes.

    Here is: http://a1209.hizliresim.com/11/5/cpqz6.png
    Go To your site’s Dashboard and Settings->Auto Attachments And Misc. Options from accordion. Set List view of Files to No. There will be no diskette.

    Tevya
    Participant

    @thefiddler

    Thanks for your help. I disabled the list view. It works. Except the formatting seems a little off. As you can see in the linked screenshot, the labels are appearing way below the icons, and covering the top of the following row’s icons. Is this a CSS issue you need to fix in the plugin, or is it my theme messing with your plugin’s CSS?

    https://picasaweb.google.com/lh/photo/xaIyxfcEt5ez7anRa24T6jLX74avLVSDu0pa-KW4s34

    Plugin Author Serkan Algur
    Member

    @kaisercrazy

    Plugin uses standart list (ul li) for listing files/items. I think i can improve this css style width id and classes.

    Thanks for info again.

    Plugin Author Serkan Algur
    Member

    @kaisercrazy

    I think with new version your problems solved.

    Tevya
    Participant

    @thefiddler

    Yes, it now works very well, and does everything I need! Thanks so much. I’ll go give it a full rating right now.

    Plugin Author Serkan Algur
    Member

    @kaisercrazy

    i am glad to see if it works for you. Thanks for your rating.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] [Plugin: Auto Attachments] Not displaying file-type icons, & enable only on certain pages?’ is closed to new replies.