Support » Plugin: AuthorSure » [Plugin: AuthorSure] Need help setting up

  • Resolved tracersa


    I must say I was quite impressed when I first saw this plugin since I have not been able to successfully setup my profile appearing in search results of google previously. I have installed this plugin and my google profile page is all setup but I am finding it a little bit hard to get started with this plugin. I visited the site, signed up as well but it doesn’t seem to have a basic starting video neither documentation as such is available for me to get a start. so any help on how to get started from level 1 will be appreciated.

    Secondly, I have a multi-author blog. I am the administrator but have ‘contributors’ as well. This is one reason I choose this plugin since the features mention that. I saw a tutorial on how to setup for a single author blog but again I couldn’t find how to do it if a blog is multi-authored??

    All in all the plugin seems quite impressive BUT I am finding it hard to setup. Please help. Any guidance will be appreciated

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Russell Jamieson



    The issue you are facing is likely down to AuthorSure checking that the author of a post is at least an “author” and not merely a “contributor”.

    This is in line with the WordPress levels of authority that indicate that a contributor can create content but not publish it. It therefore makes sense to me that if a contributor cannot publish then they are not likely to be attributed as the author of the work and hence have an “author profile” within the site.

    However we should have made this decision explicit in the AuthorSure documentation before now. We will do so.

    I am open to the idea of having a AuthorSure plugin setting that allows the minimum level of authorship to be either “author” or “contributor”

    Please let me know if you would like the option to be able to have “contributor” as the minimum authorship setting?



    I am not exactly sure which issue have you pointed to by saying

    The issue you are facing is likely down to AuthorSure checking that the author of a post is at least an “author” and not merely a “contributor”


    anyways, leaving rest aside. I have setup the plugin for almost 5 days now. The site gets indexed really fast and shows up in search result almost the very next day after a post is made BUT the picture/google authorship is not showing at all. There has been no progress whatsoever. Any help?

    (Note: I had previously setup the google authorship manually and google authorship was showing for one or two out of 100 posts so I decided to use AuthorSure thinking I must have not set it up correctly)

    Plugin Author Russell Jamieson



    Re: your first point – WordPress has several “levels” of user – AuthorSure by design will not produce author links for the 2 lowest levels; “subscriber” and “contributor”; your authors can be of level “author”, “editor” or “administrator”

    Google does not decide to show your face in the SERPS instantly – the fastest we are aware of is 8 days; the slowest is 5 months – it depends of many factors known only to Google.

    The important thing for you to do is to check whether your face appears the preview for the posts in the Google Rich Snippets Testing Tool. If it does that you have set up Google authorship correctly.

    Then all you need to do is wait – and keep writing articles and building your authority through other means.

    Plugin Author Russell Jamieson


    Just a note here, as of the 12 April or so, the Google Rich Snippets Test Tool stopped showing the preview image – it just shows up the page as being verified but there is no photo.

    I don’t know at this stage if this is a bug in the GRSTT on a manifestation of some other change that Google is planning in its implementation of AuthorRank

    Plugin Author Russell Jamieson


    Normal service was resumed on April 16th, Google Rich Snippets Test Tool is showing faces again. With the new update, Google allows you to paste in HTML as well as specifying a URL, see Updates to Rich Snippets

    I installed authorsure on a couple of blogs. All but one is working. It doesn’t show who the author is. (no choices to choose) This is weird since I am the admin and author. Any clue why that is happening? The theme is Genesis Tapestry so it shouldn’t be a problem. the url is

    Plugin Author Russell Jamieson


    Hi Rebecca,

    The issue is that you have too many rel=author links

    For this site, where you are using the ‘author box’ method, you need to remove the rel=author from the ‘About Rebecca’ menu link to the page

    Go to Appearance | Menu , and edit the main menu, select the “About Rebecca” link, make the link relationship XFN setting visible (there is a option at the top of the page to show/hide this info) and then remove the value “author”, then Save.

    Your posts/pages should then validate.

    Thank you Russell. That helps. I had previously inserted some code before finding the plugin. I was originally going to do the menu method and was surprised that my name didn’t show up as the author. I like the author box method though.

    Using the author box method I connected my Google account with the author page instead of the “about” page. Is this correct?

    Do you know if it’s necessary to validate the domain email with Google as well because I will be using this for several clients?

    Plugin Author Russell Jamieson


    It is hard to say if it is 100% necessary to make an authorship request for every domain but it will not hurt – here is a handy link

    I suspect that maybe one request per author is sufficient but Google are not clear about this.

    Thanks so much!

    We have a new staff member. The auhorbox at the end of the post shows her bio, but does not show her name.

    I can’t figure out why. She’s the only one this has happened to.

    Plugin Author Russell Jamieson


    @jbocook If you edit Nicole’s user profile on WordPress what is showing up as her “Display Name”?

    The author for the public relations lessons is Melissa Moss. Her display name should be Melissa Moss, but I also set it to Melissa.
    We’ve been able to select the author from the dropdown inside the posts box, but for some reason on Melissa it doesn’t work.

    Plugin Author Russell Jamieson


    Have you set up Melissa as a contributor? Maybe she needs to be at least an “Author”, check her assigned role/capability

    I have her set as an administrator. Her blog post shows up as author melissa, and is working correctly, but for some reason her name doesn’t show in the author box of that post.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: AuthorSure] Need help setting up’ is closed to new replies.