WordPress.org

Forums

Author Avatars List
[resolved] SSL Mixed content problems (14 posts)

  1. edwardnh
    Member
    Posted 3 years ago #

    I am using this plugin on a site that has one page which requires SSL. However, when I load this page, it gives me a mixed-content error in Chrome browser and the development tools point to this plugin as the culprit. Although I am not using the plugin for that specific page, it still loads and causes the mixed-content error. Is there anyway to get this plugin to not load its CSS or javascript except when needed?

    Here are the offending modules:
    /author-avatars/css/shortcode.css?ver=1.5.0
    /author-avatars/css/widget.css?ver=1.5.0
    /author-avatars/css/shortcode.css?ver=1.5.0
    /author-avatars/css/widget.css?ver=1.5.0

    http://wordpress.org/extend/plugins/author-avatars/

  2. Paul Bearne
    Member
    Plugin Author

    Posted 3 years ago #

    I will look at this in the next version

    I might just be a case of removing the http from the calling URL in the code so that it loads https or http as needed

    the problem about try to loading the CSS on demand it the we need it load before the widget/shortcode is called

    you list the CSS twice are both the CSS been call twice?

    Paul

  3. edwardnh
    Member
    Posted 2 years ago #

    No, it wasn't twice as far as I know. That was an error.

  4. Paul Bearne
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks

  5. GustavoSartori
    Member
    Posted 2 years ago #

    I've a similar issue (I'm using WordPress HTTPS plugin).

    In my case, i'm having troubles in my Edit page. When I try to edit or create a new post and the 'Author Avatar List' plugin is active, the editor options buttons aren't shown. When I deactive the plugin, all options works finely. Do you know why?

    I need to use your plugin, but I need use this ssl plugin too. Please, help me!

    The error seems to be as follows:

    Failed to load resource: the server responded with a status of 404 (Not found) https://linkdm.websiteseguro.com/wp-content/plugins/author-avatars/tinymce/langs/pt.js?ver=358-23156
    Failed to load: https://linkdm.websiteseguro.com/wp-content/plugins/author-avatars/tinymce/langs/pt.js
  6. Paul Bearne
    Member
    Plugin Author

    Posted 2 years ago #

    I am working on the plugin over the break I will have look at this

    it looks like the MCE lang script which I don't have

    http://plugins.trac.wordpress.org/browser/author-avatars/#trunk/tinymce/langs

    I am guessing that you are run WP in a non english admin
    can try to run the admin in english and see it that fixes it

    if is does copy this file

    http://plugins.trac.wordpress.org/browser/author-avatars/trunk/tinymce/langs/en.js

    rename it to pt.js and chanage the text Add Author Avatars Shortcodes to your language

    and if it works send to me and I will add it to the plugin

    Paul

  7. GustavoSartori
    Member
    Posted 2 years ago #

    Pbearne, first of all THANK YOU for your answer!

    Me and my partner was breaking our heads by a few weeks trying to fix this problem.

    You're right! My WP is running in Pt_br.
    I don't know how to change the Admin Panel language, so I did your second solution, and it's works! thank you! thank you! thank you!

    have a happy new year!

  8. Paul Bearne
    Member
    Plugin Author

    Posted 2 years ago #

    good news

    I will add this code to the next release

    Paul

    /plugins/author-avatars/tinymce/langs/pt.js

    tinyMCE.addI18n({
        "pt":{
            "authoravatars": {
                "desc" : "Adicionar o atalho do Author Avatar"
            }
        }
    });
  9. mikehenrysr
    Member
    Posted 2 years ago #

    I'm also having this problem in English. Whenever I enable your plugin, I lose my edit buttons when I activate your plugin. I have WordPress HTTPS activated too and need it. So what change can we make to fix this. I've had your plugin disabled for several months searching for some other way to get an author page and an authors widget and nothing works as well as this one.

    http://leadchangegroup.com

    Mike...

  10. Paul Bearne
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry to hear you are have problems

    I now have a domain I can test this on so I will do some digging

    Do you see any errors in the JS console

    Paul

  11. mikehenrysr
    Member
    Posted 2 years ago #

    I get this error

    "NetworkError: 404 Not Found - http://leadchangegroup.com/wp-content/plugins/author-avatars/tinymce/editor_plugin.js?ver=358-23224"

    And these 2 warnings
    Unknown property 'zoom'. Declaration dropped.
    zoom: 1; widget.css?ver=1.6.2 (line 9, col 206)

    Expected declaration but found '*'. Skipped to next declaration.
    *display: inline;

    widget.css?ver=1.6.2 (line 10, col 213)

  12. Paul Bearne
    Member
    Plugin Author

    Posted 2 years ago #

    can you check that the plugin installed OK as that file should be there.

    Try to reinstall delete and add and see if that fixes it

    check via FTP that the file is installed

    Paul

  13. mikehenrysr
    Member
    Posted 2 years ago #

    When I download this off of the WordPress Repository, it's 1.6.1 and many of the files are different. I did install the editor_plugin.js but is there someplace I can get 1.6.2?

  14. mikehenrysr
    Member
    Posted 2 years ago #

    However, I will say that may have solved it. Using FileZilla, I simply uploaded everything that was newer. It seems to be working now. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Author Avatars List
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic