Support » Plugins » [ Plugin: Audiobar ] permission denied

  • luaelectro22


    I upgraded to wp 3.3 and now i get this error 🙁 [ permission denied]…Does this mean that the new wp doesn’t support this plugin? It would be a shame because this is the best audio player for wordpress… Any solutions? txs

Viewing 5 replies - 1 through 5 (of 5 total)
  • Ko Ko Win


    I also had this problem. Why is it appear? 🙁

    realpath() [function.realpath]: SAFE MODE Restriction in effect. The script whose uid/gid is 1773/1771 is not allowed to access ………..

    hey Ko Ko in my case i changed the permalinks structure to default and it resolved the problem. try it.

    this is great, but id like to have it work with custom permalinks. it is a professional website and the default permalinks are a bit, well tacky.

    Hi everyone,

    Sorry for the delays. I just responded to this same problem in another thread, but I will repeat the info for the sake of ease.

    Audiobar uses something called iFrame to make it play continually. Audiobar needs to put a “#” in the URL in order to do that. Without this, the music would reset when you change pages. There may have been a conflict and your custom permalink included a hash or some other code that conflicted with iFrame.

    Any of you who had the problem – can you post what the custom permalink was that you were using? I personally am using a custom permalink with audiobar and I don’t have any problems so I figure it must have to do with the link formatting itself…

    Ko Ko Win, you are having a different problem. After some research, I found out your problem is with the host – I think your hosting is running your PHP in safe mode – meaning that they don’t allow certain changes to be made. My advice would be to contact your host (godaddy, webmasters, bluehost, etc.) and ask them to take off the restrictions.

    Alternatively, you can re-install wordpress manually to reset some permissions. That worked for some people. There are instructions to reinstall wordpress manually here:


    I get the same SAFE MODE problem as this, my hosting won’t disable safe mode because its a shared server so I’ve never been able to activate and use this plugin.

    getid3() seems to be causing all the problems by trying to write to /tmp – i’ve tried changing the folder location by editing the php files but it either ignores my changes and still tries to write to /tmp or it changes to a different error about a hash #0 or something.

    real shame, i only installed wordpress after seeing someone elses site using audiobar, as its just what i wanted my artist page to be like, but it just doesnt work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[ Plugin: Audiobar ] permission denied’ is closed to new replies.