Support » Plugins and Hacks » [Plugin: Audio Player] Version 2.0 beta released

[Plugin: Audio Player] Version 2.0 beta released

Viewing 15 replies - 256 through 270 (of 530 total)
  • @songsofthelight

    Should be activated in your plugins, In the body of the post its:
    [audio:here/is/my.mp3] and publish. Should be able to see it and hear it.

    A friend is having a hard time with this plugin.
    I have uninstalled the plugin and reinstalled the latest version.
    I have verified the folder names.
    I have verified I do have the current flash player.

    I’m still getting:

    Audio clip: Adobe Flash Player (version 9 or above) is required to play this audio clip. Download the latest version here. You also need to have JavaScript enabled in your browser.

    Getting that on several browsers.

    Any ideas would be much appreciated.
    The page I am testing with on her site is:

    Hi – great player. Superb. Been using the standalone V1 for a while now.
    Now using V2 as a standalone on my music site http://www.yopo.co.uk

    My problem is in IE opening one player on a multi player page is not shutting down the first player. Works fine in Firefox & Safari but in IE it doesn’t work. And that’s one of the features my customers loved about the V1.

    So – any ideas? I’ve tried a lot of things. If you’re interested take a look at my site at
    This is a little testing area with 2 players.

    I have this code in the header:

    <script type=”text/javascript” src=”http://www.yopo.co.uk/acatalog/audio-player.js”></script> <script type=”text/javascript”>
    AudioPlayer.setup(“http://www.yopo.co.uk/acatalog/player.swf”, {
    width: 290

    And this at the point I want to place say player 1:

    <p id=”audioplayer_1″>Alternative content</p> <script type=”text/javascript”>
    AudioPlayer.embed(“audioplayer_1”, {soundFile:

    And player 2:

    <p id=”audioplayer_2″>Alternative content</p> <script type=”text/javascript”>
    AudioPlayer.embed(“audioplayer_2”, {soundFile:

    Thanks for any help! And thanks for writing such a neat effective player.


    I am on Firefox 3, using the latest wordpress 2.6.2. I get the error message that tells you it require javascript:

    Audio clip: Adobe Flash Player (version 6 or above) is required to play this audio clip. You also need to have JavaScript enabled in your browser.

    This happens in the mixes section of my site.

    (you need a facebook account to see it though)

    Ok, it’s an ajax login… got it fixed by a fucked up way…!

    I’m using Firefox 2.0 with WordPress 2.5.1

    In my settings page, when I click to verify the audio folder location I get this message: Audio folder location not found. Please check that the following folder exists on your server: is deprecated since version Use instead./home/rhubarb/html/blog/audio

    I’ve manually added a folder named audio in my blog directory, but I’m still getting this message. Is there something I’m doing wrong?

    great plugin!!

    Hi – here’s a follow up to the V2 stanalone not working with multiple players as it used to:

    What stops it shutting down one player when you open another on the same page in Internet Explorer is when the player code is inside “Form” tags. Outside of those it works fine. But as my player is part of a product for a shopping cart it has to go inside “Form” tags. Any resolution to this please?
    Here’s some sample code: Take out the form tags and it works – leave them in and statrting one player wont shut another down.

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <title>Untitled Document</title>
    <script type="text/javascript" src="audio-player.js"></script>
    <script type="text/javascript">AudioPlayer.setup("player.swf", { width: 290 }); </script>
    <p id="audioplayer_1">Alternative content</p>
    <script type="text/javascript">
    AudioPlayer.embed("audioplayer_1", {soundFile: "http://www.yopo.co.uk/preview/upbeat/RockSolid.mp3"});
    <p id="audioplayer_2">Alternative content</p>
    <script type="text/javascript">
    AudioPlayer.embed("audioplayer_2", {soundFile: "http://www.yopo.co.uk/preview/upbeat/UrbanJungle.mp3"});

    One other thing:
    The new player doesn’t seem transparent in it’s closed state – there’s a white box that extrudes across?

    Thanks again for a great player.


    I keep getting this error…

    Warning: AudioPlayer::include(/home/content/q/y/x/qyxes1/html/wp-content/plugins/audio-player/php/options-panel.php) [function.AudioPlayer-include]: failed to open stream: No such file or directory in /home/content/q/y/x/qyxes1/html/wp-content/plugins/audio-player/audio-player.php on line 531

    Warning: AudioPlayer::include() [function.include]: Failed opening ‘/home/content/q/y/x/qyxes1/html/wp-content/plugins/audio-player/php/options-panel.php’ for inclusion (include_path=’.:/usr/local/php5/lib/php’) in /home/content/q/y/x/qyxes1/html/wp-content/plugins/audio-player/audio-player.php on line 531

    what did I do wrong?


    I’ve downloaded the latest version of the standalone player. It works perfectly in Firefox and Chrome, but I’m receiving an error in IE7. Here it is: http://www.resonancerecords.org/test/test.html

    Any idea why this is happening? I don’t understand, I’m using the sample code that was provided.




    Hi Martin,
    Well I’m not sure what I did, but I managed to break the player again. You were very kind and helpful last time, I’m hoping you can help now too?

    The problem is that in FF, when I click on any of the audio files, I get a very strange distortion–it’s almost like a 70’s “fuzz” effect, but it does not sound good. I’m running FF 3, and flash 10 beta. IE doesn’t seem to have the same problem.

    Any ideas? Anyone else having the same problem?

    (here is the site: http://blog.5alarmmusic.com/)



    Hi everyone….

    What URL encoding scheme does wpaudioplayer use? I don’t recognize the encoding visually, and I can’t find anything on it in the documentation.



    Never mind….found it.




    I’m using the stand alone version 2.0 and it works perfectly in I.E 7, yet in Firefox v2 & 3 and Safari, the stop another currently streaming player when launching a new player on the same page function does not work, in that all selected players stream / play simultaneously. I saw one post that mentioned this function not working in IE7, yet working in Firefox, etc (reverse of my experience).

    Any feedback on what may be causing this behavior?

    Many thanks for a great player…!




    Firefox 2.0
    Wordpress 2.6.1
    Version 2.0 beta Audio Player

    In FF, the players were not showing up, so I followed your directions. Thanks. It’s showing up, but now there’s a graphic that should not be there. So, I followed your directions to give the graphic a white background. It’s still not working.

    You can see it here –>> http://womenlearnthai.com/index.php/the-thai-alphabet-poem-song/

    To the left of each player, there’s a half circle with an x in the middle.

    Safari is fine.

    (btw – thanks for this brilliant plugin)

Viewing 15 replies - 256 through 270 (of 530 total)
  • The topic ‘[Plugin: Audio Player] Version 2.0 beta released’ is closed to new replies.