Support » Fixing WordPress » [Plugin: Audio Player] not compatible with WordPress 3.4

  • Unfortunately i just updated wordpress and now when i click on the “Audio Player” button to insert media from my library NOTHING HAPPENS! Now i have no idea how to stream music in my posts. Does anyone know how to insert music manually? Do you know if the creator of this plugin will update it to be compatible with 3.4?

Viewing 15 replies - 1 through 15 (of 29 total)
  • I’m experiencing the same problem and it started with the upgrade to 3.4 for me as well.

    You can manually enter the audio shortcode into your post as follows:


    Replace “http://linkToMP3File” with the “Link URL” for your audio file.

    I am having the same issue too. Clicking the Add Audio button doesn’t display the shortcode in the Link URL entry field. I’m a little worried this won’t be fixed since the plug-in hasn’t been updated since January 2010.
    Manually entering the shortcode isn’t really an option for my clients.
    Can anyone recommend a replacement plug-in?

    Aggg… Im having the same issue.. Really need help with this.

    I uploaded an audio file yester day and it was fine. Afterwards i updated and now im in trouble..

    Confirming that audio player is no longer working for me, either.

    Yes, It’s possible to do a manual link, but that’s not the same as having the audio player on my page. Are there other audio player plug-ins that are compatible?

    Yup, WP 3.4 killed the plug-in for sure. I’ve looked around the plugin depository, but haven’t found something to replace this.

    My clients love the ease of this particular plugin, and I hate to have to find something else. Even worse, I hate to have to train my clients on how to use something different.

    The manual method does not work for me. The player appears but says the file cannot be found. Kind of sucks since my site is audio-centric. Hope an update is coming but I won’t hold my breath. No updates for this plugin in 2 years!

    3.4 seems to have a problem with all audio files and plugins which is pretty annoying and no word from back office that I’ve been able to find.

    If you’re using Firefox, it could be a problem with Realplayer and you need to turn off web download and recording:

      Launch RealPlayer
      Click the RealPlayer icon in the upper left corner of the window and choose Preferences.
      Choose Download & Recording from the left hand panel
      Uncheck “Enable Web Download & Recording for these installed browsers”
      Click OK and close RealPlayer
      Restart Firefox

    I do not think it has to do.
    I think it’s a change of adding HTML to the caption.
    This problem.

    Yeah, my real player settings were already set to what you described. No dice. Still have to add the audio player by writing out the shortcode.

    at least you guys can still insert the audio tag manuallly and get it to work. When I do that it can’t find the target file when you click play. Anyone else have that behavior?

    for me, this audio player bug is the moment to switch to an other player

    you have to change the code ([audio src=])
    manually, which will be more work… yes.
    but compared to audio player it works on mobile devices like iPhone, iPad too…
    which is definitely an argument for me..
    and it has a smart design.

    I am also having problems since I updated to 3.4.

    When I upload the Mp3 and click onto audio file the URL link disappears 🙁

    Any suggestions? or do we wait for an update from the developer?


    In audio-player’s plugin files, edit audio-player.php. Line 684: change value to data-link-url

    In audio-player’s plugin files, edit audio-player.php. Line 684: change value to data-link-url

    It Work!

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Plugin: Audio Player] not compatible with WordPress 3.4’ is closed to new replies.