WordPress.org

Support

Support » Plugins and Hacks » AStickyPostOrderER » [Resolved] [Plugin: AStickyPostOrderER] Not working after update to WordPress 3.1.

[Resolved] [Plugin: AStickyPostOrderER] Not working after update to WordPress 3.1.

Viewing 15 replies - 1 through 15 (of 31 total)
  • ty for the quick patch, this works. hope it gets updated officially soon 🙂

    Thx man for “reanimate” it

    I have fixed a few more erros.
    New version of the patch you can download here: http://www.q2w3.ru/2011/02/25/3234/
    Please note – this patch working only on WP version 3.1 and newer. Do not try to install it on older versions!

    It doesn’t fix my bug. I can’t display correctly the other loops of my homepages. In any tag or any category i want to display, it display only the posts i have selected in my homepage.

    For example, when i want to display the entire content of my tag “immo” in the date order, it display the only posts which are ranked in homepage, not all the post of tag “immo”.

    <?php query_posts(‘orderby=date&tag=immo&showposts=4’);while (have_posts()) : the_post() ; ?>

    Is it a common bug?

    tostaki1, sorry, but I didn’t understand what are you doing… Can you make screenshots?

    In fact, I have two categories of news in my website. The first category is the important news, which is the main content of my website. It’s typically a loop of many posts that I control with astickypostorder. But in my sidebar, I have a second category of news ‘the short news’ (called with the tag immo in my code).

    <?php query_posts('tag=immo&showposts=4');while (have_posts()) : the_post() ; ?>

    This code aimed to display the short news in the date of their creation. Until now, these short news could be ranked in the two categories (sidebar + main content) when I decided it was a short but important news. Until the 3.1 update, the main content order was controlled by astickypostorder, and the ‘short news content’ was displayed in the order of the creation of the post.

    But when I have updated WordPress to 3.1, AstickyPostOrder has bugged (there was no post proposed for ranking). First, I decided to reinstall 0.3 version of the plugin and delete the wp_croer table and wp_croer_meta in my sql table. It has worked for the main content, but in my short news category displayed in sidebar, all the news tagged immo and ranked too in the main content were displayed first.

    I add a orderby=date in my code

    <?php query_posts('orderby=date&tag=immo&showposts=4');while (have_posts()) : the_post() ; ?>

    But it doesn’t worked too… In the same time, when I go in the tag ‘immo’ in the Astickypostorder menu, there are no content ranked at all in this section.

    tostaki1!
    Look what I found in query_posts function description:

    The query_posts() function is intended to be used to modify the main page loop only. It is not intended as a means to create secondary loops on the page. If you want to create separate Loops outside of the main one, you should use get_posts() instead. Use of query_posts() on loops other than the main one can result in your main loop becoming incorrect and possibly displaying things that you were not expecting.

    May be it will be a good idea to use get_posts() for short news block.

    Also you can add &aspo=vanilla parameter to query vars. It will disable Astickypostorder for that query.
    <?php query_posts('tag=immo&showposts=4&aspo=vanilla');while (have_posts()) : the_post() ; ?>

    yes, it works!!! I have add &aspo=vanilla and it’s the date order which is displayed

    Thanks a lot, it has make me mad…
    But where is the documentation of the plugin?

    I have an error with your fix. I get this error message:

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /…/wp-content/plugins/astickypostorderer/astickypostorderer.php on line 213

    what can I do?

    hafer!
    I have fixed this warning. Download new version of the patch (0.9.4).

    By the way. It looks like your WP configured with WP_DEBUG option set to true. It is a security risk. I recommend to switch this option off. Look at your wp-config.php for the following line:
    define('WP_DEBUG', true);
    delete it or make a comment:
    //define('WP_DEBUG', true);

    Hi Max Bond,

    you are the best! Now it’s works!

    and thank you for the tip with the debug mode!

    Hello Max,

    I have a new problem:

    Out of memory (allocated 20185088) (tried to allocate 43522 bytes) in /homepages/41/d323367702/htdocs/wp-content/plugins/astickypostorderer/croer-functions.php on line 162

    What can I do??

    Hello, tostaki1!

    What is your php memory limit value?
    20185088 bytes ~= 20 Mb – not very much for WP.
    Increase php memory limit to 32 / 64 Mb.

    Nice job Max. Thank you for stepping up to make the fix so this great plugin can continue to work.

    I’ve increased the limit to 72mb in wp-config.php, but it doesn’t work too… My provider is 1and1 and normally it allow 90mb

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] [Plugin: AStickyPostOrderER] Not working after update to WordPress 3.1.’ is closed to new replies.
Skip to toolbar