Support » Plugins » [Plugin: AskApache Password Protect] test fails

  • While upgrading WP I deactivated the AskApache plugin and on reactivating I noticed that suddenly the tests fail. I didn’t change any settings (I usually make a few folder writable before upgrading and then change them back and this time I did nothing else), but the htaccess tests (and mod_rewrite?) and something with fsock, no idea what it is. Since I have problems with newer versions I still had 4.3.2 going, but right now I can’t get any version working after the test part was built in, so now I’ve got 3.5.1 which does the job.
    I hope this explains the situation a bit…?
    Could it be that my host had changed something or did I do something stupid without realising?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve released an updated version: 4.6.5 which will hopefully work 100% for ya!

    I have activated and tried running 4.6.5 but fails running the tests (same issues as before). This plugin worked fine for me up until 4.6 was released and have not been able to get it to work since. I understand from reading various forums that this is the case for many a folk.

    (So for me… the plugin just sits there in a non active state waiting for the next version to come along. I really had my hopes pinned on 4.6.5 but will have to wait until a 4.6.6 or perhaps even a 4.7.

    The concept of AA Password Protect is excellent and when it does work it’s definitely the Roll Royce of WP defence plugins.


    I’m sticking to 4.3.2 as it’s the last version working on my blog.

    working on it….

    Hi askapache,
    I’m having the same problems with my site as well.

    4.3.2 passes all tests except PLAIN encryption (so I’ll use this for now)

    I have a couple custom additions to this V-Ded server, installed by someone at, so I don’t know if they could be contributing factors (APC and mcrypt). I also had mod_security installed and they have some special mod_security configuration file that’s supposedly near bulletproof.

    P.S. Everyone… it was only $50 for the mod_security install & setup. ‘Course, I have root & ssh access.

    If you would like my debug files or a phpinfo() or anything else, let me know, I’ll be glad to share to help everyone.
    (I’m not too crazy about posting everything here.)

    askapache… Send me an email to mailme2 at 57mgte period common and I’ll send you whatever 🙂

    Oh, two things I did discover…
    If the .htaccess or .htpasswda3 files don’t exist it will fail. So, I placed empty files where they failed.

    Also, setting the permissions to 777 causes them to fail, but setting them to 666 seems okay.


    I have the same situation as the OP.
    1. 4.6.5 working fine on WP 2.7
    2. Deactivated 4.6.5 when being migrated to a new server (host: DreamHost)
    3. Reactivated 4.6.5: all mod_xxx tests failed, except mod_sec
    4. Removed 4.6.5
    5. Installed 4.3.2: all tests are ok, except mod_sec.

    Any chance that AAPP is looking for a specific version/array of versions for mod_xxx ?



    Installed plugin and recieved this error after tests and activating the wp-login password protect.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: AskApache Password Protect] test fails’ is closed to new replies.