Support » Plugins » [Plugin: AskApache Password Protect] no configuration screen

  • I’ve used AAPP for quite some time and I upgrade regularly. Since yesterday I’m on 3.5.1. Since a few upgrades ago I have no configuration screen. This doesn’t matter since I don’t have to change anything, but should I or should I be curious about new functions, this could be helpfull. The ‘configuration screen’ only says:

    NOTE: This is an incredibly powerful plugin that modifies your server not wordpress. This can easily take your site down. If you experience a bad error, delete the .htaccess files on the server using ftp, ssh, webftp, or contact support, etc..

    And further only has out-links (About this plugin, AskApache links and Security articles). The website itself malfunctions (IE6 at work), so I figured I’d make notice of the problem here.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Please upgrade to the latest version – currently Version: 4.2.4

    Because of the extreme nature of this plugin (and my lack of time and skill at programming) I have purposefully made each upgrade to automatically erase the old version so that you have to start all over again and re-think your security posture.

    Hopefully you don’t have a exploited blog, thats weird that you are still using 3.5.1 — If you ever have a problem, just remove the modified parts of the .htaccess file in your root and wp-admin directory.

    Ah, it’s even better. I do have 4.2.4, but when I click on “AA PassPro” in settings, I get the 3.5.1 links screen… So I have to delete everything and upload the plugin again?

    Wow, just out of the blue, all my WP’s that have Ask Apache (six in total, all on the same server, all with the same usernames and password) started prompting for passwords for every click I make in the password surrounding. I thought it could be a cookie thing, but deleting them didn’t work. Even when I deactivate the plugin this remains (apparently the htaccess isn’t modified). In my test I tried to see what happens if I just try to upload the plugin again (I can’t delete anything with my PC at work) and I get a message about folder permissions. I haven’t done anything with that for some time, so I wonder why they are suddenly a problem now.
    A note to come back to the original subject of this thread: the newly updated (just 4.2.4 to 4.2.4) does have some configuration settings. I can’t use them, but it’s more than just the screen with the links that I has before.
    I figure I’ll just try to clear out everything when I’m back home and make a ‘fresh start’.

    Some new information about the thing.

    I can’t install 4.2.4 and start working. Everything I do will give me a 500 server error and nothing works any longer. I can however install an older version, I’ve used 4.2.2, and set it up the way I want. Then I can upgrade to 4.2.4, but the AA PassPro screen will tell me that I use 4.2.2. Fortunately I do have the admin screen back. WP thinks that I’m on 4.2.4, so I guess I’m happy enough, but it’s all pretty strange nonetheless.

    [edit] The internal server error goes away when I delete the htaccess in the admin folder.

    [edit again] As soon as 4.2.4 modifies files I get the server error.



    Newer users are unable to install askapache…Just see a Fatal error message on activation and nothing else happens.Even when i try to uninstall it…i get error messages…The plugin needs immediate fixes…

    I just updated a lot of the code.. could you provide me with any error message you guys are seeing? Like php errors and/or apache error logs?

    • Clear your browser cache.
    • Deactivate the plugin.
    • Delete the plugin files.
    • Download latest version and unzip.
    • Activate.


    I can’t even deactivate the plugin if I wanted to. Nor can I find the .htaccess file… how does one fix it now?



    I just created a blank .htaccess file and overwrote it.. wonder why it’s hidden.. it’s working now..

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: AskApache Password Protect] no configuration screen’ is closed to new replies.