Support » Fixing WordPress » [Plugin: AskApache Password Protect] htaccess support not found?

  • I installed AskApache and activated the plugin. When I open Options Configuration Panel, I get “htaccess support not found.”

    What does it mean? How can I make this plugin work?

Viewing 14 replies - 1 through 14 (of 14 total)
  • That is the last resort the plugin takes, it means your current server or server configuration does not work with ANY of the 4 available .htpasswd encryption algorithms.

    I will be adding support for non-apache hosted blogs in the future.

    Thank you for the quick reply.

    Please add support for non-apache hosted blogs. I badly need this plugin as I was hacked the other day. I’m just getting around with this whole blogging thing I don’t know much about those terms.

    Is there anything I can do to make it work?

    I get that message too, and my blog is hosted on an Apache server at Hostgator.

    That message will only show up if the final test fails.

    The final test is actually pretty freaking sweet, what it does is create a temporary directory with an .htaccess file similar to the one this plugin installs in your wp-admin folder. It then uses fsockopen, a function almost all php installations have, to request the password protected page. If the response from the server returned 500 or 200, then this plugin wouldn’t work for your wp-admin folder either.

    I’m hacking the code right now so stay tuned for an update.

    I upgraded from 3.6.3 (and all worked well) to 3.6.6 and files are created well but no apache authentication is required. If i downgrade to 3.6.3 your plugin works. Any suggestion? I tested also 3.6.5 but same thing: plugin doesn’t work for me.

    I’m releasing a new version in a couple hours.. try that one. 🙂

    I am getting the same error. I just install a fresh WP site and this is the first plugin I have activated.

    I am on CentOS 4.x/apache2/PHP 4.3.9

    I changed the Alloverride from None to All and restarted… I’m still getting the error. How do I enable what ever is necessary for this plugin to work?

    Try the new version, upgrade to php 5 if you can.

    I get this warning now using version 4.0.1. I probably won’t be able to upgrade to php 5.

    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/askapache-password-protect/askapache-password-protect.php on line 701

    However, the setup seems to load fine. Will see what happens next.

    I am not able to upgrade to php5. I tested last version and plugin activation was ok but in AAPro Admin Panel i have a
    “bad fsockopen”

    @ karcher

    I believe the latest version solves that bug, let me know.


    That isn’t good.. I’m already using like the most compatible lowest level networking available..

    if( false!= ($fp = @fsockopen($target, $_SERVER['SERVER_PORT'], $errno, $errstr, 15)) && is_resource($fp)){
    }else die('bad fsockopen');

    just keep upgrading

    then again it could be as simple as the funciton “is_resource” not being php4 compatible.. this plugin is going to be awesome…

    I have no problem running the latest code on Linux with Apache. I seem to have a problem with the latest code on Windows with Apache.

    After I active the plugin and attempt to use it if fails all test. In looking at my Apache error logs I see the following error:

    “AuthUserFile takes 1-2 arguments, text file containing user IDs and passwords”

    I searched the web and found out that this usually means that there is no argument or file not find after AuthUserFile. Of course there was one…C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/wp-admin/.htaccess

    What I found was that Apache did not apparently like the spaces in the file location string. I changed this line of code

    "AuthUserFile $TRp".DIRECTORY_SEPARATOR.".htpasswda1",


    'AuthUserFile "'.$TRp.DIRECTORY_SEPARATOR.'.htpasswda1"',

    and it passed the tests the script does.

    I verified this ‘spaces in the file name’ problem by moving Apache to a directory structure will no space and reran using the original code. It passed. Put a space back in and it failed.

    Thinking that little fix was easy to live with I was ready to go. However, I ran into another problem immediately. Every time I open the plugin is puts in extra DIRECTORY_SEPARATOR symbols in the .htaccess file.

    .htpasswd location: C:\Apache2.2\htdocs/.htpasswda1


    .htpasswd location: C:\\Apache2.2\\htdocs/.htpasswda1


    .htpasswd location: C:\\\Apache2.2\\\htdocs/.htpasswda1

    for each subsequent access to the configuration page. Clicking on Modify .htaccess actually writes the extra directory separators. (This happens if the directory structure contains spaces)

    Since I am no code jockey and I hoping you can address and make this plugin work in both environments.

    Running test site on:
    Windows XP SP2
    Apache for Windows 2.2.8
    PHP for Windows 5.2.5
    MySQL for Windows 5.0.r12


    Thanks. seems to have taken care of the warning. Oh, and thanks for fixing the checkbox display too.

    The only very minor thing is that at the top of the options page, beneath the links to your website and .htaccess tutorials, but above the “AskApache Password Protect” heading, I always see the following characters:


    This seems purely cosmetic though. The plug-in appears to be working fine for me now.

    Sorry for the late reply. I’ve been out of town…

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: AskApache Password Protect] htaccess support not found?’ is closed to new replies.