Support » Fixing WordPress » [Plugin: AskApache Google 404] Plugin is not working

  • Hi, i installed the plugin but i don’t have a 404.php page. I think is in index.php the code that displys the message with nothing found. How can i make a 404 page and how can i make my searches from my blog to search on the page i will make with 404?? my blog is

Viewing 9 replies - 1 through 9 (of 9 total)
  • askapache


    sorinu~ the latest version 4.7.1 includes a 404.php file by default.. 🙂



    Hi askapache – I hope you get to see this.

    I’ve just installed the update but it’s breaking my custom 404 page – see for an example, with the WordPress database error message (“Can’t find FULLTEXT index matching the column list”).

    I’ve added ob_start and exit calls to the template, as detailed in the settings page. I get the same error when choosing your default 404 template too. Can you help?

    While I’m here, any chance of adding an apostrophe to “Googles best guess”? It’s always bugged me 😉



    First you should turn off displaying errors (for security) by adding this to your wp-config.php file.


    Uh oh, I wonder why my code didn’t get executed when you activated the plugin, which fixed this issue by first dropping the post_related index and then creating a new one upon plugin activation. So somehow that didn’t happen. Try deactivating and then reactivating the plugin.

    I wonder if someone could take a look at the create_function code and see if I’m doing something wrong.

    here’s the SQL that is supposed to have been executed…

    ALTER TABLE $wpdb->posts DROP INDEX post_related, ADD FULLTEXT post_related (post_name,post_content);

    to change the apostrophe issue just edit the javascript from the plugin options page.

    gSearchGoogleGuess.setUserDefinedLabel("Googles Best Guess");

    Replace with whatever you want..



    Hmm. I added that line to wp-config.php, but the errors continued to show up until I disabled the Show Related Posts option. That seemed to fix it.

    I still can’t get any Google results to show, though. They’re fine in the preview, just not on the live site. I’ve rechecked the Google API key, which is correct.

    Thanks for the info on the apostrophe – at least I’ve fixed that!




    the google results won’t show up for but will show up for something like:


    (@askapache) .. hope thats the last emergency bug for today..



    the fix was:

    $wpdb->query('ALTER TABLE '.$wpdb->posts.' ENGINE = MYISAM;');
    $wpdb->query('ALTER TABLE '.$wpdb->posts.' DROP INDEX post_related');
    $wpdb->query('ALTER TABLE '.$wpdb->posts.' ADD FULLTEXT post_related ( post_title , post_content )');


    Fantastic – many thanks askapache!


    I just wrote a post in a different thread about the CSS code not saving changes and I have an issue with the Googles Best Guess also, it never shows anything for me. Just letting you know.

    EDIT: I just found out the HTML section of settings page also doesn’t save changes, I just tried. Not sure about the Javascript section, I don’t mess with JS.

    Also at the very top, just checked again – the 404 section doesn’t save changes when choosing which 404 page to use.


    • CSS code area of settings page doesn’t save changes made to it
    • Googles Best Guess is always 0, show’s nothing
    • HTML section doesn’t save changes
    • 404 section at top doesn’t save changes when picking which 404 page to use

    I will disable this for now and reinstall it later. I will check back here in hopes you may be fixing these things.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: AskApache Google 404] Plugin is not working’ is closed to new replies.