Support » Plugins » [Plugin: AsideShop] Works in testing mode (when logged in), not when enabled

  • I am rather confused. I have the plugin working perfectly fine when the testing mode option checked – Enable AsideShop for testing. (Only logged-in administrators can see changes on the front page.)

    However, once I log out (whether I am in testing mode OR if I have fully enabled the plugin), it reverts back to a regular post. The div class=asides part disappears. And yet, it’s there when I am logged in as admin and viewing the site.

    Here’s my site, I currently have it on the testing mode so it looks fine to me when I am logged in, but not correct when I view it once logged out.

    Anyone have any ideas? Is it simply due to not being compatible with 2.6 yet (which, I know, it says on the plugin page that it is only compatible up to 2.5.1)? If that’s the case, I guess I’ll just have to wait until an update and will likely hold off on using “asides” on my blog for now 🙁


Viewing 11 replies - 1 through 11 (of 11 total)
  • nifty,

    What’s the address of your website? Your wordpress profile doesn’t seem to work.

    It’s true, I haven’t tested it on WordPress 2.6 yet but I will soon. So some glitches are possible in untested environment.

    Thanks for the feedback!

    Hi maijs,

    I could have swore I put in the URL in the post, hrmm. Oh well.

    Here’s my blog (the top post, re: Orbitz post is the asides post).
    EDIT: Apparently the link just doesn’t show up. Let’s try this

    Thanks maijs!


    I see that you are using Blue Zinfandel 2-Column theme, I download it and activated in my testing environment and it works for me. Even when I log out I still see the changes.

    I’ve just released version 1.0.6 of AsideShop, checked it against WordPress 2.6 and I think it’s compatible. Fixed also couple of bugs.

    Try to upgrade AsideShop, purge all your browser’s cache and try again. It should work.

    Hey maijs,

    Thanks for the quick response. I’ve updated it to 1.0.6 and cleared my cache. (As well as deactivated and reactivated the plugin a few times) Still no luck 🙁

    Here’s how it looks when I am logged in, using testing mode:

    The code on the page, under content middle, looks like how it should

    <div class="asides" id="post-87"> X-Entertainment has a tribute to <a href="">Dead Sodas</a> and it includes my beloved Orbitz (I think it was beloved, or maybe my fondness of nostalgia has clouded my memory). Remember Orbitz? With those non-descript floating balls inside them? Good times. <a href="">(0)</a></div>
    <br />

    However, once I go to Enable AsideShop (where it is now, currently), it still reverts back to the usual code:

    <div class="contentdate">
    		<div id="post-87"><div class="contenttitle">
    			<h1><a href="" rel="bookmark"><!--enpts-->Dead Sodas: Orbitz<!--enpte--></a></h1>
    			<p>Filed Under <!--enp_cat_start--><a href="" title="View all posts in Asides" rel="category tag">Asides</a><!--enp_cat_end--> | <a href="" title="Comment on <!--enpts-->Dead Sodas: Orbitz<!--enpte-->">Leave a Comment</a>&nbsp; <a href=";post=87" title="Edit post">(Edit Post)</a></p>
    			<p><!--enp_content_start-->X-Entertainment has a tribute to <a href="" onclick="javascript:pageTracker._trackPageview ('/outbound/');">Dead Sodas</a> and it includes my beloved Orbitz (I think it was beloved, or maybe my fondness of nostalgia has clouded my memory). Remember Orbitz? With those non-descript floating balls inside them? Good times.<!--enp_content_end--><br /><a href="javascript:enp_edit(87)">Edit N Place</a></p>
    <div class="post-teaser"><a href="" title="Permanent Link: Dead Sodas: Orbitz" rel="bookmark"><b>Permanent link to this post</b></a><br /> (42 words, estimated 10  secs reading time)</div><div style="clear:both;"></div>
    			<div class="postspace">
    			<rdf:RDF xmlns:rdf=""
    			<rdf:Description rdf:about=""
        dc:title="Dead Sodas: Orbitz"
        trackback:ping="" />

    I’ve also deactivated some of the plugins I thought were conflicting with the plugin, i.e. Post Teaser, Edit N Place, and the_excerpt Reloaded and it seems to still not show up properly =\ I thought it had to do with Edit N Place because of the way there has to be some editing of template (via instructions here -> but I am unsure if that is definitely the problem since it works dandy in testing mode.


    I’m having the same problem that nifty is. It works in testing mode, but not in the enabled mode.

    Ugh. Having the same problem. But this may help narrow it.

    When I look at my blog at – asides show up. But if I look at it ar, which is a redirecty thing, the aside styling disappear…


    I am using AsideShop 1.0.8 with wordpress 2.7 and have the same problem.

    I see my changes in testing mode but it reverts back to old normal post when I enable it.

    Is there something I can do?

    My blog can be accessed at

    And again, sorry, is there a way I could hardcode it and enable it in the asideshop.php file?

    OK I’ve found the cause, my WordPress loops.

    I use a loop in the index.php to display my posts and another in the sidebar.php in order to show the last post of one category.

    Here is the sidebar.php loop which is called before the index.php:

    <?php $my_query = new WP_Query('category_name=pensees&showposts=1'); while ($my_query->have_posts()) : $my_query->the_post(); $do_not_duplicate = $post->ID;?>
    		<div id="post-<?php the_ID(); ?>">
    		<h3 class="sidetitle"><a href="<?php the_permalink() ?>" rel="bookmark"><?php the_title(); ?></a></h3>
    			<div class="penseecontent">
    			<?php the_content(__('(more...)')); ?>
    		<?php endwhile; ?>

    Here is the index.php loop:

    <?php if (have_posts()) : while (have_posts()) : the_post(); if( $post->ID == $do_not_duplicate ) continue; update_post_caches($posts); ?>
    		<?php if (in_category('7') && is_home() ) continue; ?>
    		<div class="post" id="post-<?php the_ID(); ?>"><div class="post-other"><div class="post-ie">
    		<h3 class="storytitle"><a href="<?php the_permalink() ?>" rel="bookmark"><?php the_title(); ?></a></h3>
    			<div class="storycontent">
    			<?php the_content(__('(more...)')); ?>
    			<?php comments_template(); // Get wp-comments.php template ?>
    		<?php endwhile; else: ?>
    		<?php _e('Sorry, no posts matched your criteria.'); ?>
    		<?php endif; ?>

    If I call the sidebar.php after the plugin works fine. But my design is messed up.

    By the way this causes this other problem too.

    I too am having this issue.

    The asides appear correctly in Testing Mode on the Front Page, and they appear correctly in Enabled Mode on the Category Page. But not in Enabled Mode on the Front Page.

    So I’m guessing its some sort of problem with my index loop. But I’m not sure what kind of problem to look for.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: AsideShop] Works in testing mode (when logged in), not when enabled’ is closed to new replies.