WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Arconix FAQ] FAQ Page Blank On Frontend

[Resolved] [Plugin: Arconix FAQ] FAQ Page Blank On Frontend

  • I recently activated Arconix FAQ. Created a few groups and FAQs and created a page with ONLY the [faq] shortcode.

    When I go to this page on the frontend, the page is completely blank.

    Previously, I was using Easy Content Types from http://pippinsplugins.com to create a FAQ section, but I came across your plugin and decided to give it a try because I didn’t want to go through creating all the templates required with ECT.

    Before starting, I deleted the FAQ custom post type, taxonomies and templates that were created automatically with ECT.

    I then activated AFAQ and all the previous FAQ items I had created were recognized by AFAQ. I created “Groups” and assigned each FAQ to a group. I then created a “Frequently Asked Questions” page and added the [faq] shortcode.

    I should also note that I still use ECT for other custom post types.

    http://wordpress.org/extend/plugins/arconix-faq/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author John Gardner

    @jgardner03

    Hi tpflanz,

    Thank you for giving my plugin a shot. Is this running on a website I can go visit? It’s really bizarre that you’re seeing nothing output. I don’t think there should be a conflict between ECT and AFAQ, but that may be something I may need to test out a bit.

    Thanks

    Here is the link to the FAQ. I am positive it is a conflict with ECT. I have tested by deactivating all plugins and only activating ECT.

    Right now, all plugins I intend to use are activated, including ECT.

    http://dev.joesdatacenter.com/frequently-asked-questions

    Plugin Author John Gardner

    @jgardner03

    I was hoping some data was being output, but it looks like the query that drives the FAQs is coming up empty. Very odd.

    I went to pippin’s website and just saw that ECT is not a free plugin, so testing it is going to be a bit difficult. Would you be able/willing to create a user for me on your website so I can log in and take a look at what’s going on? If you would like, please e-mail the credentials to john@arconixpc.com

    I sent you credentials.

    Plugin Author John Gardner

    @jgardner03

    Thanks for the login. After debugging it a bit, it looks like when I don’t use the “groups” taxonomy, the FAQ’s load just fine (you can test this by deleting the “dedicated-servers” FAQ group and reloading the FAQ page). As soon as a group is created, the WordPress query fails because it can’t seem to find any faqs that belong to that taxonomy, despite 6 being listed. That is actually the case whether it’s the query in my plugin, or the ECT custom query — I used the following shortcode based on the ECT documentation: [ecpt_query post_type="faq" tax="dedicated-servers"] and it found no posts.

    I think the next step would be to use the ECT plugin to create a “groups” taxonomy and see if that gets it working, but I’m hesitant to make such a change on someone else’s site without giving you a heads up or anything to get your input.

    I probably initially created a custom taxonomy with ECT for the FAQ section with the name “Dedicated Servers”. Could that be the issue?

    What steps should I take to check the database? Or I could export it, if you want to take a look.

    Thanks again for your help.

    Plugin Author John Gardner

    @jgardner03

    Could that be the issue?

    That could be, I suppose. What I didn’t think to do was to create an additional taxonomy (VPS server or something) and assign FAQs to that group to see if that changes the behavior at all.

    If you want to give that a shot and let me know how you make out, or I’ll take a look at it tonight and let you know how I make out.

    I tried creating groups and adding FAQ items to them. Still a blank page.

    The groups I created to test:

    Virtual Private Servers
    VPS FAQs

    I tried both because just in case, since there is a custom taxonomy of “Dedicated Servers” and “Virtual Private Servers” which are both used by ECT for services offered.

    Feel free to test in whatever method you need. I have backed up everything.

    Go to Content Types > Settings and check the box for “Disable Taxonomy Archive Fix”. That should do it.

    Plugin Author John Gardner

    @jgardner03

    Thanks for the quick note! I’ll give it a shot.

    Edit: Thank you very much Pippin… that worked like a champ.

    Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Plugin: Arconix FAQ] FAQ Page Blank On Frontend’ is closed to new replies.