WordPress.org

Forums

Arconix FAQ
[resolved] display all questions on a page (15 posts)

  1. AliKat
    Member
    Posted 2 years ago #

  2. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Alison,

    Than you for using my plugin, and I apologize for the delay. The plugin should default to showing all items. Do you have a live version of the plugin running so I might be able to take a look at it and see what is going on?

  3. AldrinD
    Member
    Posted 2 years ago #

    noticed this issue was marked as resolved, will make new

  4. chickc
    Member
    Posted 2 years ago #

    I am also having an issue with the number of FAQ posts on a page. Only 5 are showing, but I have 6 published in the admin. Shouldn't it be unlimited?

    http://www.webwizards.pro/testpage/

  5. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi chickc,

    Yes, the default is to show all items. Just to test this out and make sure I wasn't crazy, I created a fresh WordPress site, went to Settings > Reading to change the default to 5 posts and then created a FAQ page. I didn't have any issues seeing all the FAQ items I created --
    http://test.arconixpc.com/frequently-asked-questions/

    The only thing on that page is [faq]

    Off the top of my head, if you're not setting showposts="5" in your faq shortcode, I'm not sure why you'd be seeing any fewer than all the FAQ items.

    It would seem to be either another plugin or the theme itself is coming in after my query is created and modifying the post parameters. If they were, this would be how: http://codex.wordpress.org/Plugin_API/Action_Reference/pre_get_posts

  6. chickc
    Member
    Posted 2 years ago #

    Ok thanks. I will check it out and report my findings.

  7. chickc
    Member
    Posted 2 years ago #

    Nope, just not happening. I'm running WordPress 3.4.2 and all i have on the page is [faq] and there's nothing after it. Its too bad, I really love the way this plugin handles otherwise.

  8. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    It's either the theme or another pouting that's causing your troubles. The best way to figure out which one is to disable your other plugins one at a time until you find the offending one(s). If you disable all the plugins and the issue still exists, then try changing to a default WordPress theme like twenty ten and see what happens.

  9. chickc
    Member
    Posted 2 years ago #

    ok I will give it a shot. Thanks.

  10. chickc
    Member
    Posted 2 years ago #

    Ok found it. The theme I was using had a setting to limit the numbers of posts on a page. Your plugin works fine. Thanks for your help.

  11. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    Good to hear everything is working!

  12. idomagic
    Member
    Posted 2 years ago #

    I am having the same problem but cannot locate the offending plug in seeing as even with "non" activate, it only shows 5. I assume this is a theme or CSS setting but I am at a loss. Any advice on a css overrride would be great.

  13. idomagic
    Member
    Posted 2 years ago #

    OK, I found the theme over-rides the number of posts available. Maybe post some CSS code to show how to kill any potential theme conflict. You FAZ, which I may add is amazing, does not work well with any ElegantTheme.com theme. To work you need to configure in their unique theme set (under Archived) or you should provide some CSS ;)

    https://www.elegantthemes.com/

  14. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi idomagic,

    Unfortunately there is no CSS I could provide you that would help override theme code. The theme code (index.php, page.php etc...) handles the extraction of WordPress data and outputs it to the display. All CSS does is make that data look pretty.

    What setting do you have to change to get all the FAQ items to show? I'll see if I can get in touch w/ the guys over at ET and see how I might be able to override that setting in my plugin.

  15. alvarezlouie
    Member
    Posted 2 years ago #

    idomagic

    im having the same 5 FAQ listing limit and using elegant themes as well, what and where did you change in you ET to display properly?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Arconix FAQ
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic