Support » Fixing WordPress » Plugin API HTTP Error

  • I am trying to install plugins from the dashboard, but when I try to search or use the featured or popular button, I get the following error:
    An Unexpected HTTP Error occurred during the API request.

    How do I resolve this issue?

Viewing 15 replies - 16 through 30 (of 41 total)
  • Same problem – I did a little digging and found the problem. There’s some command called fsockopen that is usually disabled on free hosts: I’m using freehostia and they apparently disabled it. This means that wordpress doesn’t have access to html freely and can’t look up the plugin directory, theme directory, or automatic update directory. It stinks… Anybody know a free host with reasonable storage and bandwidth that has fsockopen enabled?

    Food Blogger

    (@biglistofgiveaways)

    Extending the time to timeout worked for me! Thanks efree!

    delphig

    (@delphig)

    WP_Error Object ( [errors] => Array ( [http_request_failed] => Array ( [0] => Empty reply from server ) ) [error_data] => Array ( ) )

    After setting the debug as per paavels comment this is what I get..
    Anyone with ideas.. Still getting the API timeout

    rogeriomello

    (@rogeriomello)

    efree_unix, thanks for the tip of timeout. It solved not just this problem, as also another one I was having with attachments.
    (don’t ask me how, but it was magically solved after I changed the http.php)

    Obstinate

    (@obstinate)

    I wish it solved mine. About an hour ago I started getting this message for the first time ever. I’ve not installed any plugins for over a week. I only have about 10. Now I can’t access my dashboard at all. It has been giving me the API message for almost an hour now. I’m stuck. 🙁

    *UPDATE*

    Sexybookmarks was the culprit. I’ve just uninstalled it via FTP and hey presto! 🙂

    scharfenberg

    (@scharfenberg)

    I had the same problem on several sites with WP. I also disabled Sexybookmarks by FTP and it solved the problem.

    Hope there will be a fix for this as Sexybookmarks is a very popular plugin.

    Paradisewriter

    (@paradisewriter)

    Obsinate,

    I am getting the same error and also have Sexybookmarks installed. I am in FTP right now and am wondering if I just delete it to uninstall? If not, please share the steps you followed to uninstall it.

    Thank you and Happy Thanksgiving!

    Obstinate

    (@obstinate)

    Hey, Paradisewriter

    Yep, that’s literally all I done via FTP. I found the SexyBookmarks folder, clicked delete (again, all through FTP) – then I went back to my dashboard and clicked ‘Try again’ and it worked. Everything was back to normal. It was a 2 second job that had me pulling my hair out for an hour!

    Good luck. 🙂

    Paradisewriter

    (@paradisewriter)

    Obstinate,

    Worked like a charm! I too was pulling my hair out for the last hour or so, thank you so much for taking the time out of your Thanksgiving day to respond.

    A Big Mahalo (thank you)!

    bojanglin

    (@bojanglin)

    Thanks for the tip Obstinate. I had the same exact issue today and it never happened to me before. I just deleted Sexybookmarks from my FTP account and everything is now fine!

    Happy Thanksgiving everyone!!

    alliant

    (@alliant)

    Same issue here in ATL on 3 WP sites JUST TODAY ONLY, called GoDaddy no help. Did the 30 time thing, no change. No sexybook marks. Why today when I have time to work on sites? Thanks, Michael

    eight7teen

    (@eight7teen)

    Bravo to everyone who made the mass assumption that SexyBookmarks was to blame… In all actuality, it’s a WordPress issue.

    SexyBookmarks makes use of the WordPress API, and therefore yes, disabling the plugin will “fix” your problem… However, there are countless others of you who do not have, nor have ever had SexyBookmarks installed who have run into the same issue. Coincidence?

    Before everyone points the shameless finger of blame in the wrong direction, why not ask WP to either FIX it’s API, or maybe just post up some damn documentation so that plugin developers aren’t using “guesswork” in terms of accessing it?

    Don’t believe me? Check this out: http://api.wordpress.org/

    ijango

    (@ijango)

    I have multiple Wp sites up and running, hosted through GoDaddy. Just started two new ones this evening. I’m getting the same error not only on my news sites without any plugins ( Except askimet )but also my old ones. I cannot upload themes or plugins. The WP RSS feeds on the dashboard are also not populating due to the same error. HTTP error & Timed out & cannot connect to host. Any suggestions?????

    GoDaddy says it’s all good on there end. WP must be having a problem.

    Thanks,

    J

    wpjordan

    (@wpjordan)

    Hi All — I am having this problem without SexyBookmarks (or any other plugin) installed.

    Has been about 12 hours since this started.

    New installation, new site. No plugins other than defaults. Only default theme installed. Changed the WP-Includes/http.php from default 5, to 45, with no change.

    Any suggestions or ideas?

    Thanks,
    Jordan

    chandlerwhite

    (@chandlerwhite)

    This really sucks. WP, where are you? Something’s going on on your end. Step up to the plate, let us know, and address it!

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Plugin API HTTP Error’ is closed to new replies.