Support » Plugin: AP Extended MIME Types » [Plugin: AP Extended MIME Types] Mime type for .dmg Files

  • I’m trying to use this plugin to upload .dmg files. I did some searching online and found tried this:

    dmg application/octet-stream

    Still not being allowed to upload. We have this activated on a single site on a multi-site network. Any thoughts? It worked with exe. Also added this to the network settings for allowed file types just in case. Still no dice. Thanks for any thoughts you can offer.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Josh Maxwell


    Try this MIME Type: application/x-apple-diskimage

    Grrr.. that is still not working. Any other ideas? Do I need to restart the server or something. Or should it take effect right away?

    Plugin Author Josh Maxwell


    Try octet-stream without the application/ bit.

    Hmmm… no dice. Here is what I have tried.

    dmg octet-stream
    dmg x-apple-diskimage
    dmg application/x-apple-diskimage

    All of them still give me the “[filename] has failed to upload due to an error
    Sorry, this file type is not permitted for security reasons.”

    Thanks so much for your help.

    Plugin Author Josh Maxwell


    Can you give me some details about your server config? And are you self-hosted or do you use a hosting company?

    We are self hosted. This is at It is a multisite subdomain site ( It is a pretty complicated setup with 4 servers a load balancer in front of it, etc. I can get more info. I don’t maintain the infrastructure myself. Is there something I should be asking in particular?

    We are working on setting up a multi-site instance to replace all webservices at UNC. This will host and a variety of other huge traffic sites. We really want to activate this plugin site wide (with a network option) and were going to look to modify the plugin for that later so we can set it for the whole site.

    Anyway, thanks for your help and thoughts. Seems to be working great for other file types (exe application/octet-stream).

    Plugin Author Josh Maxwell


    I altered my mime-types.txt to include dmg application/octet-stream and tried uploading this file (1.8MB) and it worked.

    My server is a 2008 WinXP running IIS 7. I’m not sure what the difference is between my setup and your’s, though. There could be another security issue (such as an .htaccess file) located on your server. Check with your SysAdmin.

    Could you tell me what size your DMG is? Also, I suggest trying to upload the file above so we have the same test file.

    Another suggestion: deactivate the plugin, edit the mime-types.txt file to add in the mime type, restart the IIS or Apache service (depending on your server) or your whole server, then reactivate the plugin.

    We’ll figure it out 🙂

    Just an update. I downloaded the file above and had the same results. I did deactivate the plugin and make the changes and reactivate it with the same results. Going to check with the sys admin to see if they have any thoughts. Thanks for your help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: AP Extended MIME Types] Mime type for .dmg Files’ is closed to new replies.