WordPress.org

Forums

amr users
[resolved] problem with single checkbox custom field in s2member (2 posts)

  1. aliferis
    Member
    Posted 3 years ago #

    I followed your guide below:

    http://wpusersplugin.com/3086/user-lists-and-filtering-with-s2member-fields/

    Problem is that, when I use a group of single checkboxes in S2member and then use your technique to create a single field in a list using x.y numbering in the display order column of the list, In the list column I just get a '1' for every checkbox in the group - not the value of the field.

    eg

    list = sellers
    list question = 'what countries do you operate in?'
    question options: UK, USA, ITALY, SPAIN, FRANCE

    List config:

    Display order: 5.1,5.2,5.3,5.4,5.5

    List view:

    Seller countries: 1 1 1 1 1

    Whereas I need to see - list view:

    UK, USA, ITALY, SPAIN, FRANCE

    It seems like this bit of help in the aforementioned guide is not correct (or my WP/S2 is not working right)

    For me, it seems as if single checkboxes also work like this:

    “rental2″ => “1″
    “activities2″ =>”1″
    “liftpass2″=>”1″

    ---------------------------------------------------------------------------

    How S2 stores their data
    Multi Options:

    “service_type”
    “Life passes”
    “Ski rental”
    “Activities”

    Single Checkboxes

    “liftpasses” =>”Lift passes”;
    “activities” =>”Activities”;
    “rental”=> “Rental”

    Radio Buttons

    “rental2″ => “1″
    “activities2″ =>”1″
    “liftpass2″=>”1″

    Thanks

    Joe

    http://wordpress.org/extend/plugins/amr-users/

  2. anmari
    Member
    Plugin Author

    Posted 3 years ago #

    Hi marking this as closed as we spent quite a bit of time on this elsewhere - by email I think

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • amr users
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags