Support » Plugins and Hacks » [Resolved] [Plugin: Amazon SES DKIM Mailer] Error message

[Resolved] [Plugin: Amazon SES DKIM Mailer] Error message

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am also facing the same issue, If anyone got the fix please let me know.

    Sam Hotchkiss


    Amazon has changed the way that their responses are set up.

    To fix this problem, open the file “class.amazonses.php” in the “php-mailer” folder of the plugin.

    Go to line 133, which should say:
    $tmpar = explode(" ", $response_http_headers, 3);

    Change this to:
    $tmpar = explode(" ", $response_content, 3);

    and you’ll be good to go!

    If you’d rather, I’ve put together a patched version of the plugin that you can use– just replace the version on your site with this version– all of your settings will be retained:

    Using the version in your zip file, I get this error when sending the test: AmazonSES Error: 0000013a1d3d42fa-defa4fbf-85c9-44dd-8c8e-a6af944bf023-000000 3c87b1b5-0be8-11e2-835f-d54f391dcc98

    Sam Hotchkiss


    Chris– if you can send me an email with a screen shot of your settings and this error (my email address is on http://www.hotchkissconsulting.com/ ), I’ll see what I can do. This patch worked for 6 different clients of mine who are all running Amazon SES

    I just sent the screenshot to you. Thanks.



    Well I have situation with send via this plugin
    Amazon SES is OK is not only 200

    in amazonses.class.php
    @@ -145,1 +145,1 @@
    -        if ($response_http_status_code === "200")
    +        if (in_array($response_http_status_code, array("200", "201", "204", "206")))

    Changing line 133 worked for me…thanks Sam!

    THANK YOU Sam Hotchkiss!!
    Your patched zip of Amazon SES DKIM Mailer WORKS!!

    Thank you, Sam Hotchkiss. Your fix on line 133 works for me.

    No problem, guys!

    Note that the new version 1.3 of this plugin DOES NOT have this 8 month old fix applied. I had mistakenly believed that one of the comments in the changelog meant this was corrected in the plugin code, but this is not the case. You will have to apply these patches again with version 1.3.

    If the new plugin developer is listening, is this code available on github so that community members could apply the patch to help avoid this regression again?

    Plugin Author Roger MacRae


    Sorry everyone, I just uploaded version 1.5 and the fix is included

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: Amazon SES DKIM Mailer] Error message’ is closed to new replies.