Support » Plugin: Amazon Machine Tags » [Plugin: Amazon Machine Tags] No connection to Amazon Web Services when validating key

  • Resolved djeyewater

    (@djeyewater)


    I recently upgraded WordPress and PHP. I have re-created the cache folder for the AMTAP plugin, but am getting the error ‘No connection to Amazon Web Services when validating key’ when I save settings in the admin panel.

    I have done a bit of debugging, and the request to Amazon is receiving back a 410 Gone HTTP code.

    If I access the request url manually in my browser it returns an xml response, along with the 410 Gone header:

    <?xml version="1.0"?>
    <HelpErrorResponse xmlns="http://ecs.amazonaws.com/doc/2009-07-01/"><Error><Code>Deprecated</Code><Message>Feature Help is deprecated.</Message></Error><RequestID>ea422d8f-a9f3-4a20-ad10-3eb9e45a4354</RequestID></HelpErrorResponse>

    The request url looks like this:
    http://xml-us.amznxslt.com/onca/xml?AWSAccessKeyId=XXX&About=ItemIds&ContentType=text%2Fplain&HelpType=ResponseGroup&Operation=Help&ResponseGroup=Help&Service=AWSECommerceService&Style=http%3A%2F%2Fwww.domain.com%2Fblog%2Fwp-content%2Fplugins%2Famazon-machine-tags%2Famtap-key-verification.v3.xsl&Timestamp=2010-10-25T08%3A21%3A26Z&Version=2009-07-01&Signature=XXX%3D

    Any idea what the problem is?

    Thanks

    Dave

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having the same problem (same error message) 🙁

    Plugin Author Martin Kliehm

    (@kliehm)

    Oh, it’s confusing how often Amazon changes it’s product names and documentation. From the XML response I read that “Help” has been deprecated in the current API. In my plugin the Help response group is used for key validation. So that’s the cause.

    I need more time to look for an alternative in the API documentation. In the meantime you can hack it by adding a file amtap-aws-key-verification.txt in the wp-content/cache folder where the content is “true”.

    I have a amtap-aws-key-verification.txt file in the cache folder as generated by the plugin but it is a 0 byte file w no content. – thx

    Plugin Author Martin Kliehm

    (@kliehm)

    Fine, then please edit the content so that it is true. That hack will work for the moment.

    Simply adding the text “true” to the verification file does indeed reactivate the amtap links in posts 🙂 Thank you 🙂

    Currently, if you re-save the options on the plugin admin page it will replace the “hacked” verification file with a new blank file, so if you want the hack to work let adding the “true” text to the verification file be the last thing you do.

    Thx 🙂

    Finally got it working for me too – I had an additional problem in that there was a line break in amtap-aws-key-verification.txt after where I had added the ‘true’ text.

    Unfortunately this line break didn’t show up in gedit, which I used to add the text and view the file, so it took me quite a while to figure out what the problem was! I had to use a different text editor to edit the file that allowed me to see the line break and remove it.

    rrhobbs

    (@rrhobbs)

    Amazon Tags quit working again awhile back – trying Amazon Product In a Post Plugin for a while

    djeyewater

    (@djeyewater)

    rrhobbs Amazon Machine tags plugin is working okay on my site

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Amazon Machine Tags] No connection to Amazon Web Services when validating key’ is closed to new replies.