Amazon Link
[resolved] Plugin Not Working except iFrame (5 posts)

  1. timothylb
    Posted 3 years ago #

    I can't seem to get the Amazon Link plugin to work for me. Maybe I am missing something here, but I can get the iFrame template to display and none of the others. I tried just putting %PRICE% and I get a dash "-". Also tried TITLE and others like %PRICE%US% with no output. Using %ASIN% in the template, I do get the code to display.

    I have a new AWS account and have done nothing with it except get the keys. Do I have to configure a service inside AWS?


    Multinational Link = 0
    Localise Amazon Link = 0
    Global Defaults = 1
    Create Search Links = 0
    Live Data = 1
    New Window Link = 0

    Default Country = US
    AWS Public Key = populated
    AWS Private key = populated
    AWS Keys Validated = 1
    Debug Output = 1

    Cache Data Age = 24
    Cache is enabled

    The Template I would like to use:

    <div class="price">%PRICE%</div>
    <div class="clear"></div>

    Thanks for the help.



  2. paulstuttard
    Plugin Author

    Posted 3 years ago #

    Thanks for trying the plugin Tim,

    Everything you have set looks okay, what shortcode are you using in your post?


  3. timothylb
    Posted 3 years ago #

    Thanks for the help.

    Here is the shortcode: [amazon asin=B001FA1O0O&template=thumbnail&chan=default]

    In my site I have the images and descriptions custom. I only wish to use Amazon Link as a price updater so I don't have to manually update prices from time-to-time.

    I can confirm iFrame, Banner and Carousel work fine. I overrwote the thumbnail template with the code from my original post.

    output is only a dash "-" with no price. If I replace %PRICE% with %ASIN% I get the code. If I use %TITLE% the output is blank.


    <!-- Amazon Link: Version:3.0.2 - Args: asin=B001FA1O0O&template=thumbnail&chan=default
    [nonce] =>
    [template] => thumbnail
    [chan] => default
    [text] => http://www.amazon.com
    [image_class] => wishlist_image
    [wishlist_template] => my favourites
    [wishlist_items] => 5
    [wishlist_type] => Similar
    [multi_cc] =>
    [localise] =>
    [global_over] => 2
    [search_link] =>
    [search_text] =>
    [live] => 2
    [new_window] =>
    [default_cc] => us
    [aws_help] =>
    [pub_key] => *******************
    [priv_key] => **************************
    [aws_valid] =>
    [debug] => 2
    [cache_age] => 24
    [cache_enabled] => 1
    [asin] => Array
    [0] => B001FA1O0O

    [in_post] => 1
    --><div class="price">-</div>

  4. paulstuttard
    Plugin Author

    Posted 3 years ago #

    Hi Tim,

    Just done some testing of my own and I think it is because that ASIN is not for a particular product by for a 'parent' product (e.g. An iPod). You probably need to use a specific variant of the iPod (e.g. 32Gb, white) to get the AWS to return a price.

    Can you try doing the same thing with a different ASIN, e.g. does exactly the same shortcode, template and settings but with 0340993782 as the asin work? Just to double check that it is not a fault in the plugin.



    Here is what I did for a bit of background:

    First, I tried to add a link with that ASIN and the AWS does not find it (even though it is listed on the amazon.com site)!

    Next... - doing a lookup manually and I get this response from the AWS:

    Error =>
    Code => AWS.ECommerceService.ItemNotAccessible
    Message => This item is not accessible through the Product Advertising API.

    So it looks like it definitely can't be accessed via the AWS, bad luck!

    Next... - A quick google of 'AWS.ECommerceService.ItemNotAccessible' led me to this post on the forums:


    I'll guess because you're using the Parent ASIN.

    Variations include:
    Try using the 'Variations' response group ...

  5. timothylb
    Posted 3 years ago #

    Paul - you're a genius! it was the parent code that it didn't like... Nice support man, keep up the good work.

    Here is a cool resource I found while digging.. it lets you try out codes in aws: http://associates-amazon.s3.amazonaws.com/scratchpad/index.html

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Amazon Link
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic