Support » Plugin: Kaltura All-in-One Video Plugin for WordPress » [Plugin: All in One Video Pack] HTTP 500 with Multisite 3.1 and plugin v 2.4.3

  • Resolved j0emv



    I just wanted to post a quick message here with a fix for a problem I ran into trying to use the all in one video pack with wordpress 3.1 and multisite enabled. I would get HTTP 500 error messages whenever I tried to access “Network Admin” pages, but site admin pages worked fine. If I disabled the plugin, then I would be able to access all pages as normal. Once the plugin is enabled, I lost access to the network admin panel. The fix I found was that in the all in one video pack.php and all in one video pack widget.php or whatever those files are called, they reference:


    This does not work in multisite because for some reason, it was trying to call the WordPress settings.php file. When I plugged in the full path to the all in one video pack’s settings.php file, all error messages went away and I am able to access all administration pages with the plugin enabled. For my installation, I replaced that line with the path:


    I did this in both all-in-one-video-pack/all_in_one_video_pack.php and all-in-one-video-pack/all_in_one_video_pack_widget.php. The path may be different for your installation. Hopefully this bug is found out in the next release.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I can confirm that activating the All in One Video Pack plugin in multisite (subdirectories), either activated on an individual multisite blog or as a network activation, causes the Network Admin page to become a blank page.

    Giving the local settings.php file an absolute path in all_in_one_video_pack.php did allow me to access the Network Admin page, but then I got the error “The plugin generated 31313 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”

    Uninstalling for now.



    hi…..i found this on my 2nd day – dont know how i missed it in all my google/worpdress searches – EXACT same problem

    I just found it and after 2 re-installs, am just happy that it wasnt me or my shared server. Will try it out and revert….




    wp 3.1.4 and aio video pack 2.4.3 were giving the error as mentioned in the first post. So i deleted all wordpress (backed up files and exported XML first), re-installed wp 3.1.4, multisite, subdirectories, imported blog xml and uploaded content.

    when i installed the video pack the error was diff – at the time of activation, it would give error in capabilities.php on line 1028 – am giving up for now)



    Same issue for me i have uninstalled for now using file manager and The Network Admin page is back online.

    I will reinstall and try the fix in the first post.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: All in One Video Pack] HTTP 500 with Multisite 3.1 and plugin v 2.4.3’ is closed to new replies.